WebDAV authentication with seafdav

Hello,

been using Seafile for quite some time now. Over the holidays I wanted to enable WebDAV for a certain usecase but I can’t manage to get it working.

I’ve tried community versions 7.1.[3-5] as well as the recent pro version 7.1.9 on Ubuntu 18.04 and 20.04 - to no avail.

The following recurring errors show up in the logs as follows:

2020-12-30 13:41:25.886 - <140162390398784> wsgidav.wsgidav_app         INFO    :  X.X.X.X - (anonymous) - [2020-12-30 12:41:25] "HEAD /" elap=0.000sec -> 401 Not Authorized
2020-12-30 13:41:27.410 - <140162390398784> wsgidav.dc.domain_controller WARNING :  User testuser doesn't exist
2020-12-30 13:41:27.411 - <140162390398784> wsgidav.http_authenticator  WARNING :  Authentication (basic) failed for user 'testuser', realm 'Seafile Authentication'.
2020-12-30 13:41:27.413 - <140162390398784> wsgidav.wsgidav_app         INFO    :  X.X.X.X - (anonymous) - [2020-12-30 12:41:27] "HEAD /" elap=0.009sec -> 401 Not Authorized

The testuser can access via Seahub and Seafile client without any problems so it might to do with my conf/seafdav.conf:

[WEBDAV]
enabled = true
port = 8089 # intentionally customized port
fastcgi = false
share_name = /seafdav

For testing purposes and in order to exclude any further sources of error I tried connecting directly onto port 8089 and no Apache or Nginx and no https. Also, I tried a vanilla setup with out of the box config on a testing machine - with no success.

Does anyone have a clue as to where to look next?

Kind regards
digo

Solved - in reply to myself:
the error was caused due to using login id instead of email. For regular logins the login id works, but not for WebDAV. There it has to be the email address. HTH someone later on.

1 Like