WebDAV over https?

Is it possible to get WebDAV over https? I have it config with NGINX reversed proxy and it’s working for the windows client, ios client and also the webbpage.

Of course, why shouldn’t it?

How do I make it go over HTTPS then? Or is it included in the reverce proxy in NGINX setup?

Yes, it is within the proxy for nginx which usually already provides SSL.

You need to enable SSL for fastCGI in the WebDAV part as well:

location /seafdav {
        fastcgi_param   SCRIPT_FILENAME     $document_root$fastcgi_script_name;
        fastcgi_param   PATH_INFO           $fastcgi_script_name;

        fastcgi_param   SERVER_PROTOCOL     $server_protocol;
        fastcgi_param   QUERY_STRING        $query_string;
        fastcgi_param   REQUEST_METHOD      $request_method;
        fastcgi_param   CONTENT_TYPE        $content_type;
        fastcgi_param   CONTENT_LENGTH      $content_length;
        fastcgi_param   SERVER_ADDR         $server_addr;
        fastcgi_param   SERVER_PORT         $server_port;
        fastcgi_param   SERVER_NAME         $server_name;
        fastcgi_param   HTTPS               on;
        fastcgi_param   HTTP_SCHEME         https;

        client_max_body_size 0;
        proxy_connect_timeout  36000s;
        proxy_read_timeout  36000s;
        proxy_send_timeout  36000s;
        send_timeout  36000s;

        # This option is only available for Nginx >= 1.8.0. See more details below.
        proxy_request_buffering off;

        access_log      /var/log/nginx/seafdav.access.log;
        error_log       /var/log/nginx/seafdav.error.log;

Ok, so I just need to copy that in to my nginx config and then it should work?
And ofc, add the webdav config to seafile.config file.

More or less, yes!

Thanks, I’m currently re-installing windows server now as everything did get messed up because of the veeam installation I did think it was stucked but it was’ent it was just taking time to download and unpack the SQL express so becuase of that everything did crash. But I did not have anything importent to save so I’m just re-installing the os and then after that I’ll start up the Seafile VM again :slight_smile:

No Backup? :smiley:
You may try Proxmox if there is nothing else on this machine rather than Windows Server.

No, no backup on this machine sadly…


this don´t works because i get a 502 Error Bad Gateway “Web server received an invalid response while acting as a gateway or proxy server.”
I use nginx version 1.18.0
My seafdav.conf in /var/www/vhosts//seafile/conf
enabled = true
port = 8080
fastcgi = false
share_name = /seafdav

That i`m doing wrong?