Why it always prompts "username invalid"

I have installed seafile integrated with ldap, and I can successfully login to the server with ldap account’s uid via web browser. But when I try to share a private folder to other users login with ldap account, it always tells “username invalid”. No more fail log. Can anyone help me. Thanks a lot.

Think it need to be shared with their email address.

Hi shoeper. Thanks so much for your kindly reply. I tried to share the folder to an email address, but it failed again, telling “User nowing-fly@163.com not found”. It seems that the target email should already register as a user in the seafile system?

I think the issue with ldap is, that the user needs to login first.

With the pro edition it is possible to run an ldap sync, which could fix the problem.

Thanks shoeper.

I finally found out that the LOGIN_ATTR should be configured to mail instead of uid so that users have to login with their emails and then seafile will keep them. And then “Share to user” function can be shared via such emails.

The LOGIN_ATTR was set to uid previously but the community version doesn’t sync any email into seafile which caused the above problem.

And now my question changed to, how can I login with uid while keeping email in seafile. How to configure it in ccnet.conf?

I have the exact same issue. It has nothing to do with the user not having logged in first, because I already did that. It seems that the Seafile code at this stage does not take into account that another LDAP attribute is picked for the login attribute. This seems to me as a bug. Not sure where to report these though,


Seafile does not support it, because in an early stage it was decided to use the email as identifier.

Why put it in ccnet.conf then? It is defined in there as a parameter and it works for logging in if you change it. I successfully logged in with the mail attribute or the uid attribute.