Windows Seafile Client 6.0.6 fails to sync with https

This is more of an fyi for those getting the same issue I was getting on my PC. I installed the 32-bit version of the Seafile Server on an old Dell Machine running Centos 7 using MariaDB and Nginx as a proxy for https. There were no issues when accessing files and uploading files via the web browser, but when I installed the Windows Client (v. 6.0.6) I kept getting Failed to establish secure connection. Please check server SSL certificate I read everything I could concerning SSL certificates and how they work, but couldn’t find an answer.

Ultimately, I failed to look at the options that the Seafile Windows Client had for the user to configure. Under Settings you will find an option that says Do not verify server certificate in HTTPS syncing. Once this was marked off it worked instantly. This of course works well in a local LAN setting like my own setup. I’m not sure if this would be okay if you are sharing this through the internet though…