Workflow on editing txt or md files

I have a seafile server up and running.
Everything works as expected. I am pretty happy with everything. Syncing on all devices and editing via web interface is no big deal.

The only thing i am missing: how to edit files on the android client? I can open txt files with desired editors on my phone. But how to save changes on seafile?

I am probably missing something (I am new to android anyways) and I hope, someone can explain how to get files edited?

Thanks a lot!

We are adding the feature of editing txt and markdown file in the Android app.


That sounds very good!

Any hint as to when this might be available? It is exactly what I need!

You can download from

Via Android playstrore im running 2.2.6
On that link I see it is two versions behind. (2.2.8)

Is this for safety reasons? I don’t normally install APK manually and prefer playstore.

I’ve installed the 2.2.8 apk to test. It works … sometimes!

In the libraries view, if I click on one of the files it downloads from the server if needed, then attempts to open the file. With the new apk if I click on either a .txt or .md file it opens the inbuilt file viewer. This works 100%.

However, if I next click on the pencil button to edit the file it SOMETIMES opens an editor which works fine (I can edit and save the file as expected). The problem is that this only happens about 1 time in 10 or 20 attempts. Most of the time it just pops up a message to say “Can’t find an app to open this file” (I have removed any other android text editor apps to avoid any confusion).

I can’t find any pattern. It doesn’t seem to matter whether the file is already synced in the cache, it doesn’t matter if it is an encrypted library. I get the same “occasional” success.

Any ideas?

We will publish it to Google Play after it is tested by some users.

I have no problem with markdown file. Do you use txt?

I have tried it with both .md and .txt files, same result.

I have now installed the client on a second device and it fails the same way. Both are Samsung devices with Android 7.0.

In all cases when I click on a file within a library the client opens the (read only) viewer but when I click on the pencil icon to edit it gives the “Can’t find an app…” error message. When I first tried 2.2.8 the launch of the editor occasionally worked, but now it always fails. I have not managed to get into the editor on either device for > 24hrs now.