Wrong version? bug?

Just upgraded Seafile from 6.2.8 to 6.2.10 by running upgrade/minor-upgrade.sh. It is taking a while at “migrating avatars …” but then DONE.

However, when checking in GUI - About, it is still showing 6.2.8?

Also when going to System Admin, the link is https://myserver/sysadmin/ and it is showing my avatar with Yes / No button.

However, when I click to Settings, then click to System Admin, the link is https://myserver/sys/useradmin/ and it is showing system admin page normally, even not all the links in the left menu is working.

Bug?

No one from Seafile saw this? Today, the GUI was totally a mess, I needed to downgrade to 6.2.8.

Only suggestion I have is to look at the seafile-server-latest symbolic link and make certain it points to the newer version. Based on the information you provided, it sounds as if seafile may have been pulling info from the older version. Additionally, it could have something to do with caching. Have you tried clearing history and cleaning up temporary cache files from the computer/browser from which you are logging into Seafile? There may also be some caching going on with your web server.

Thanks for answering.

  1. Yes, the seafile-server-latest was pointed to the 6.2.10 version.
  2. No, it’s not because of caching. I tried to clear cache, tried different browsers. The login screen was fine. But after logging in, it was a mess. Changed back to 6.2.8 brought everything back to normal.

Also, the links I reported in the first post was not in 6.2.8 either. It is in 6.2.10. No one else noticed that?

Yes, but you also reported that it shows version 6.2.8 in the GUI even though you had 6.2.10 installed. The problems you are having are related to the web objects in Seafile, and it appears that the Web UI is grabbing outdated files or from the wrong folder. There are a lot of people who use 6.2.10 who are having no issues with the GUI.

Not knowing anything else about your setup, I can’t tell you where to begin to look for the problems. It could be a backend web server issue involving a wrong pointer or caching issue… It could be a version mismatch with a dependency.

The two things I suggested you look at were the most likely culprit. However, since those aren’t the issue, we need to take a look at error logs for Seafile and error logs for your backend web server, if any. We may also need to look at your web server configuration.

What web server, if any are you using? What OS are you using? With some more information, we’ll be able to narrow this down.

I am using Nginx on CentOS 7.
Thanks.

Can you look for any errors in the Seafile logs and post them here? Also, check the NGinx logs for any errors. I checked the changelogs between 6.2.8 and 6.2.10 and did not find any changes related to the web ui. Most all the changes had to do with searches and file handling. We may also have a permissions problem as well. When you updated Seafile, did you run the script as the user to whom Seafile belongs or root? Did it generate any error messages or anything?

1 Like

It looks like the command seahub.sh stop didn’t fully stop seahub. So, when I checked in cli again, it’s definitely still running on 6.2.8. That would create conflict.

I manually killed all seahub, seafile commands in 6.2.8, run upgrade again, and the 6.2.10 seems to be fine now.

Thanks again.

BTW, as an added note, here’s what the minor upgrade script does:

  • It first moves the Avatars from the previous version folder (6.2.8) to the new version folder (6.2.10).
  • It then looks for the path of the seafile-server-latest and then makes certain that /seahub/media/custom exists and copies the old custom folder to the new installation.
  • Next, it looks for the media symlink and creates it if it doesn’t exist.
  • Finally, it updates the latest server symlinks.

There are several things that could cause any one of those to fail…

  • Starting the minor upgrade script from the wrong folder.
  • Permissions problem with the user running the script, particulary with the avatars, custom, and media folder and/or files
  • Corrupt file system
  • Unhandled exceptions
2 Likes

We both commented at the same time… lol… Glad it’s working… .

@shoeper, can you mark this one as solved?