A couple of questions regarding Real-Time Backup Server


#1

I’m running a seafile server and a real-time backup server, using a crontab script to dump the databases every hour and sync them to the backup server.

Everything seems to be working fine except:

The backup server has some kind of issue with a specific file - I’m tailing seafile.log and after any sync I have an error message for a specific file:

[04/11/2019 01:26:49 PM] ../common/fs-mgr.c(1314): [fs mgr] Failed to read file 12r5684dqw34ae48r27c7f841qk6d447609bbt33g.
[04/11/2019 01:26:49 PM] ../common/fs-mgr.c(2370): [fs mgr] Failed to find file 12r5684dqw34ae48r27c7f841qk6d447609bbt33g.

I’ve run seaf-fsck on the main server and it didn’t found any issue; when I manually sync the library using /seaf-backup-cmd.sh it syncs successfully but the error keeps showing up next time there is a change - always the same file id.

  • can I run seaf-fsck on the backup server to check for any errors? I assume I would need to import the current mysql dump before doing it but not sure if it is possible and/or if it will fix anything? how can i solve the issue otherwise?

I have imported one mysql dump into the real-time backup server to test that everything was working using the instructions in the manual found here:
https://manual.seafile.com/deploy_pro/real_time_backup.html

I used the command

mysql -u <user> -p<pass> < dbdump.sql

The import was apparently successful and I just restarted the backup server without any other change (so it continues operating as a real-time backup server).

  • If there is a future failure and I need to import again the latest dump, can I just use the same command and it will overwrite the previous import and update the databases to the latest version? Or do i need to clear the databases from the previous import before attempting to do it again?

Thank in advance for your help.


#2

bumping… anyone?


#3

Hi Fred,

  1. can I run seaf-fsck on backup server?

yes. it is possible to run seaf-fsck on the real-time backup server. Stop all seafile-services and then just run the seaf-fsck.sh.

  1. can I reimport the dump?

yes. There is no problem in reimport the dbdump.sql. If you exported the database like described in the manual then your dump will look like:

DROP TABLE IF EXISTS `Branch`;
CREATE TABLE `Branch` ( ...
LOCK TABLES `Branch` WRITE;
INSERT INTO `Branch` VALUES ( ...

Das heißt, die existierenden Tabelle (mit Ausnahme von Repo, RepoHead und Branch) werden gedroppt und dann mit den aktuellen Werten gefüllt.

  1. general

I would try to get to know what kind of file that is. That should help to determine the source of the problem.

Best regards
Christoph


#4

Hi Cristoph,

Thank you very much for your help.

I’ve looked into one of the sql dumps and it does have the configuration as you posted; I’ve shut down seafile service, imported the latest dump and run a seaf-fsck on the backup server - everything went through smoothly and no errors detected. I’m thrilled to have a proper working seafile set-up with real-time backup server.

Any way to find what file it refers to by its id?

Many thanks once again.