After Upgrade from CE 7.0.4 to 7.1.4 no download/upload of files possible in the web gui

I’m running the CE edition seafile 7.0.4 on a webserver with CENTOS 7 / python 3.6 and nginx without any problems.
WEBDAV is not enabled. FAST CGI is not enabled.

After having upgraded to version 7.1.4 I can’t download and upload files in the web gui although I can run through all the libraries and see all the files - any ideas?- I checked the logs but couldn’t detect any errors.

Any help is appreciated.

Mike

Hello and welcome to the Seafile forum

did you execute the following commands for the transition to version 7.1.x

  • For CentOS 7/8

    yum install python3 python3-setuptools python3-pip -y

    sudo pip3 install --timeout=3600 Pillow pylibmc captcha jinja2 sqlalchemy \
    django-pylibmc django-simple-captcha python3-ldap

Source: https://manual.seafile.com/upgrade/upgrade_notes_for_7.1.x/

Hello,
thanks for your hints.
I wasn’t quite sure, whether I did these commands and executed them again.
I got the messages nothing to do and with the second command everything satisified… So no success. When I try to download a file in the web gui I still receive the error “waiting for server” and “failed to download the file xxx”. And furtheron no error messages in the log…

Sorry,
I looked for the error logs in the wrong folder.

There is an error in the seahub error log:

grafik

Hello,

I added the line:

proxy_http_version 1.1; to my nginx configuration file and restartet nginx.
And got now no error message in the seahub.error.log but a new error message in the nginx error.log:

2021/03/21 11:54:55 [error] 26495#0: *860 connect() failed (111: Connection refused) while connecting to upstream, client:xx.xxx.xxx.xx, server: yy.yy.yy, request: "POST /seafhttp/repo/head-commits-multi/ HTTP/1.1", upstream: "http://127.0.0.1:8082/repo/head-commits-multi/", host: "yy.yy.yy"

I hope this information helps to locate the error?

did you configure or modify the SERVICE_URL and FILE_SEVER_ROOT?

No … I let all conf file as they are.
Actually I downgraded to 7.0.4 no problem… everything works fine

I have to ask what might seem to be a stupid question: Were you using Favorites bookmarks/links to go to directories in 7.1.5 that subsuquently had the upload/download problems?

I’ve been tracking a problem in CE 8.0.3 wherein if I go to a folder using a Favorite link (left side bar) I cannot create/edit (files or folders), upload or download from that folder. If I navigate sequentially through the folder hierarchy to the destination folder, or go up the directory tree and back down again, manually, things will work. Is that at all similar to what you saw?

-Thank you.

No, i’m not using Favorites bookmarks/links.
It doesn’t matter how I navigate to the file I want to download.

Could it be a python3.6/nginx problem?
Another assumption is, that the SSL-configuration with Certbot is not working together with 7.1.4 when I want to download a file in the webinterface/Android App - however the windows app is working fine.

It reminds me a lot of the problem in 8.0.X where files cannot be moved, renamed or deleted. As far as I know that has been treated with a modification to the Nginx configuration. Another related example is here.

That said, I’m not aware of anything like your problem under 7.1.X, just 8.0.X. I think I have seen the Favorites issue under 7.1.X but at present I am not in the position to confirm or deny that suspicion.