Android app just chewed through 7 gigs of cellular data today

Topic says it all. I’ve been using Seafile for a while now and never had this issue before. No changes have been made to the server or app recently. The data usage settings on my phone shows Seafile as the culprit.

If I look at my usage logs it seems to have started happening about 8 this morning - I wasn’t doing anything seafile or photo related with my phone.

I briefly looked at Wakelock detector before uninstalling the app (to stop the data usage) and it shows over 100,000 CPU wake ups for what looked like the camera photo upload feature, but looking at my account info on the web client shows no changes made to any files today.

What can I look at further to figure out where the app got stuck at?


1 Like

Can you check the file upload/download list at the android client?

Hi Daniel,

Unfortunately it’s empty since I uninstalled the app (panic mode on my part after text from Verizon).

Is there anything server side I can look at?

Can you check Nginx/Apache log to check what were being uploaded?

Looking at the logs, the only thing that occurred today was when I uploaded a file at 9:30 this morning:

[root@cloud nginx]# zgrep -i android access.log-20170418.gz - - [17/Apr/2017:09:31:32 -0500] “POST /seafhttp/upload-api/a82ac83d-7569-4136-96f5-35425a202607 HTTP/1.1” 200 40 “-” “Dalvik/2.1.0 (Linux; U; Android 7.1.1; Nexus 6P Build/NUF26N)” “”

There’s no other traffic at all from my phone that has been recorded there.

That doesn’t make much sense. Is there other traffic that could have accounted for it that I can see server side in different logs? I looked at the logs under the “logs” folder but didn’t see anything right away. Like I mentioned earlier, looking at the bandwidth-per-app usage info on my phone, Seafile is the one that shows up as the culprit.

Here’s the other weird thing. I am running my Seafile setup behind Cloudflare. Verizon usage logs shows the data being used up yesterday:

However Cloudflare doesn’t show nearly as much being used. The spikes in the graphs correspond with the times that Verizon is showing GB of data was used, however not nearly to the same extent:

Thoughts? Does the Android app communicate with any other systems besides my own Seafile server?

We had the same problem with a user but I don’t have more information about this issue.

A possible cause was that the Android client tries to upload a file again and again when failed. This was fixed in the latest version.

But why did this cause 7 GB traffic? And why is there nothing in the server logs?

I mean a possible cause for your problem. This issue is another problem with unknown cause.

1 Like

Thanks Daniel!

I was already using the latest version unfortunately.

Any other ideas? Is there a way to enable a debugging or profiling of some sort for the app so that if this happens again I can track down the cause?

Reminds me a lot of what we discussed here and there.
To my understanding the root cause was never solved, was it?

Does seem similar for sure! I have no encrypted libraries on my server though.

In these threads, there are three different issues that causing the huge traffic problem:

  1. Auto-uploading photos to encrypted libraries
  2. Auto-uploading images that are viewed on the Android client
  3. Traffic to unknown source (this thread)

The first problem was solved in the latest version. The second problem is not reproduced yet. The third problem is caused by unknown reason.

Thanks Daniel,

For my specific issue (#3), are there any additional things I can do to troubleshoot the problem?

I think I know what happened.

On Sunday I recorded a video with my phone that ended up about 125 MB or so in size.

I run my Seafile server behind Cloudflare, and unbeknownst to me, Cloudflare has a 100MB file size upload limit. When the app reaches 100% upload on this file, Cloudflare tells it it failed, and the app starts over. It seems to try many, many times (not the 3 like the Android release notes state) before exhaustively giving up :slight_smile:

The app tried to upload this file several times on Sunday (1.39GB data used), Monday morning (2+ GB used) and Monday evening (another 2+ GB used).

When troubleshooting a separate issue I discovered this problem that was being caused by Cloudflare. Disabling Cloudflare resulted in this file being uploaded without any issues.

I am going to say there’s a solid chance this is my issue, and what chewed up all my bandwidth.

Too bad the Android app doesn’t use chunked uploading!


Was the video automatically uploaded to the server via the auto-uploading feature?

Yes. I had auto upload of photos and videos enabled over both wifi and cellular.