Android doesn´t sync photos nor upload

I am using Seafile on my personal Server. Since the last update from Android, I cannot upload any photos.
It always says upload failed.

It also doesn´t sync the photos. (Well, I aways had problems with that :frowning: )

What can i do?? How can I find out what the problem is??

Thank you for your answers…


Check your server logs to see if there are any clues there. What version of the Server are you running and what version of the app is installed on your Android?

Depending on the version you are running you could have been hit by this -->
Uploading not working at all in 2.2.2, and no error shown

@thanatos - Version 2.2.1 is the latest version on Google Play. That’s the stable version.

@whtess - so? I can’t see him mentioning any version. Also, if he used the fdroid store he could already be on 2.2.3 :wink:

Yes, I’ll agree. But, 2.2.1 is the stable version. I had asked him about the version he was using, but never got an answer. If he is using 2.2.2 or 2.2.3, he should be fine by reverting to 2.2.1. I was about to add more info to my last comment regarding Android, as well. Version 8.X (Oreo), Contacts backup doesn’t work. I’m thinking that photo sync probably won’t either, but I have not yet tried it.

Uploading with 2.2.1 and Oreo, however, works fine for me.

I just tried Photos backup with 8.0 of Android and 2.2.1 of the app. Photos Backup is working perfectly.

UUPS… Sorry I was not online… I use 2.2.3 from F-droid… I will go back to 2.2.1 to check… I am from Europe… We try to avoid Google :slight_smile:


THANK YOU SOOOO MUCH. Version 2.2.1 is stable.

Strange … But ok…

1 Like

2.2.2 and 2.2.3 are still in beta afaik.

Hm… I have 2.3.2 (from f-droid it seems) and upload is not working for me :confused:

try 2.3.4, works fine on Android 13

It’s not (yet?) available on f-droid (Seafile | F-Droid - Free and Open Source Android App Repository) :frowning:

So I did some digging in and it turns out that the app build was disabled:

pointing to

Author of seafile client seems to insist that “it won’t build and that’s that”, which is “less than ideal”. Updating from the webpage is cumbersome and there is no autoupdate…

This is a mistake from one of our developer. We will look into the issue.

1 Like

Awesome! <3