Apache 2.4 error load module

Hello,

Apache does not start. The loading of some modules seems to be in question.
Here is the error:
apache2: Syntax error on line 219 of /etc/apache2/apache2.conf: Syntax error on line 3 of /etc/apache2/sites-enabled/000-default.conf: module unixd_module is built-in and can’t be loaded

My configuration:
Debian 8
Seafile Community Edition 6.2.2
Apache 2.4.10
I am trying to make seafile and Onlyoffice with Apache work.
We use onlyoffice with nginx and it works very well. We want to do sso with shibboleth which is only compatible with Apache.

My virtual host files:
LoadModule authn_core_module modules/mod_authn_core.so
LoadModule authz_core_module modules/mod_authz_core.so
LoadModule unixd_module modules/mod_unixd.so
LoadModule proxy_module modules/mod_proxy.so
LoadModule proxy_http_module modules/mod_proxy_http.so
LoadModule proxy_wstunnel_module modules/mod_proxy_wstunnel.so
LoadModule headers_module modules/mod_headers.so
LoadModule setenvif_module modules/mod_setenvif.so

User daemon
Group daemon

<VirtualHost *:80>
ServerName xxxxxxxxxx
ServerAlias xxxxxxxxxxx
Redirect permanent / https://xxxxxx

Thanks for any help

For clear, this is not Apache forum and if you read your error message you can see what is wrong.

In file /etc/apache2/sites-enabled/000-default.conf you are loading on line 3 unixd module which is build-in (I guess it’s deprecated as module … ?) and cannot be loaded.

Please first read your problem. You have ability to write questiong in English. So you have ability to READ your mistakes in configuration…

This will fix it

LoadModule authn_core_module modules/mod_authn_core.so
LoadModule authz_core_module modules/mod_authz_core.so
#LoadModule unixd_module modules/mod_unixd.so
LoadModule proxy_module modules/mod_proxy.so
LoadModule proxy_http_module modules/mod_proxy_http.so
LoadModule proxy_wstunnel_module modules/mod_proxy_wstunnel.so
LoadModule headers_module modules/mod_headers.so
LoadModule setenvif_module modules/mod_setenvif.so

User daemon
Group daemon


ServerName xxxxxxxxxx
ServerAlias xxxxxxxxxxx
Redirect permanent / https://xxxxxx1

......

Thank you for your reply.
I understood that I did not post on an Apache forum. I posted on this forum because I followed the Seafile user manual.
https://manual.seafile.com/deploy/only_office.html
I took the example given in the manual.

Before my first post, I had commented on the lines that were problematic. But it continued to produce other errors.

Excuse me for my low level of English.
AS

It’s OK

Setup OnlyOffice docker container.
Setup you Apache VHOST for OnlyOnly office like this:

<IfModule mod_ssl.c>
<VirtualHost *:443>
        # The ServerName directive sets the request scheme, hostname and port that
        # the server uses to identify itself. This is used when creating
        # redirection URLs. In the context of virtual hosts, the ServerName
        # specifies what hostname must appear in the request's Host: header to
        # match this virtual host. For the default virtual host (this file) this
        # value is not decisive as it is used as a last resort host regardless.
        # However, you must set it for any further virtual host explicitly.

        ServerName <your.onlyoffice.domain>

        ServerAdmin <your@mail>
        DocumentRoot </some/document/root>

        # Let's encrypt setup ... uncomment if use it
        #SSLEngine ON
        #SSLCertificateFile <certificate/file>
        #SSLCertificateKeyFile <certificate/key/file>
        #Include /etc/letsencrypt/options-ssl-apache.conf


        RewriteEngine On


        SetEnvIf Host "^(.*)$" THE_HOST=$1
        RequestHeader setifempty X-Forwarded-Proto https
        RequestHeader setifempty X-Forwarded-Host %{THE_HOST}e
        ProxyAddHeaders Off

        SSLProxyVerify none
        SSLProxyCheckPeerCN off
        SSLProxyCheckPeerName off
        SSLProxyCheckPeerExpire off
        ProxyPass / http://127.0.0.1:<http port to your docker container>/
        ProxyPassReverse / http://127.0.0.1:<http port to your docker container>/
        ProxyPassMatch ^/(.*\websocket)$ wss://localhost:<https port to your docker container>/$1
        ProxyPassReverse /websocket wss://localhost:<https port to your docker container>/websocket
</VirtualHost>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet
</IfModule>

Setup you Seahub config file like manual you post saying