Avatar URL wrong in Seafile CE 7.0.5 deployed with docker

I deployed seafile CE with docker. The corresponding seafile version inside the docker image is shown as Server Version: 7.0.5. The ports are both 80 and 443. The avatar loading always shows incorrect url as http://file.xxx.com:8000/media/avatars. The screenshot is shown as follow:

My seafile service url is set as:

  • SERVICE_URL: https://file.xxx.com
  • FILE_SERVER_ROOT: https://file.xxx.com/seafhttp

where xxx.com corresponds to our company domain name.

The configuration of nginx within docker image is by default. Does anyone suggest how to resolve this issue?

Hi, I have the same issue.
I have tried to follow this


but it doesn’t work with my setup. I have a Synology.

I found a solution, and it helps, but it is in Chinese.

https:// bbs.seafile. com/t/topic/11537
(sorry for I can;t include url.)

In summary, you should delete tmp/seahub_cache, and the seafile will renew and apply your settings.(in my comprehension.)

However, I deployed seafile with docker, and there is not a tmp/seahub_cache, but I restart the memcached, and it works.

docker restart seafile-memcached

like above.