[Bug]Share directory download doesnt work

Hi There,

i noticed the following with CE 7.0.4.

If you share a directoy via share-link and click one file for file preview, the big download buttom in the middle does not work. It links to the wrong link, only the top right one works.

You have to share a directory to reproduce this, sharing a single file seems to work.

Feedback is appreciated. Thanks!

push no one that can confirm?

I tried both the Share Link and the Share to User buttons and both seem to work as advertised. Can you say more about what you are doing and what you see at your end? -Thanks

Seafile 7.0.4 CE, Ubuntu 18.04, Nginx



may you share a folder via link and post it here or pm it to me to test?

For me if i try to share a folder and preview one file in the link, the big download bottom does not work. Same for friend of mine on his install.

Both setups use CE7.0.4 on Debian. One with Nginx, one with Traeffic.

For reproduction:

  • share folder via link (file works fine)
  • open the link and try to preview a file (the download buttom on the folder view works)
  • use the big download buttom

I can confirm the problem.

The problem only emerges when there is no preview active in Seahub for the file format. When you try to reproduce with PDFs, JPGs, ā€¦ in the shared folder, the problem does not show.

The screenshot below shows the problem with an EML file. When clicking on the grey download button, Seahub jumps back in the directory view rather than downloading the file.

1 Like

Thanks for the feedback.

@daniel.pan is this known?


Iā€™m confused. This is what I see. Both buttons work.

Seafile CE 7.0.4 | Ubuntu 18.04 LTS | Nginx

Are you, @mercury, trying to download the file via a folder share link? You seem to try to download an EML-file as a logged-in user.

Sorry, my mistake. When I attempt to download a file with no preview from a shared folder or Library I get the same error. The grey download button reverts to the previous directory listing.

1 Like

We will look into the problem.

1 Like

Fixed in 7.0.5