Can't create download links after upgrade to 6.1.1. "Links" section shows "Error"


We have Seafile installed on latest Centos (VPS) and after upgrade (with the minor upgrade script) from 6.0.9 to 6.1.1 (64 bit) we can’t create download links for files anymore. When you click on the share icon you get the share pop-up and the loading icon keeps loading forever. Before the upgrade this functionality worked OK.

Also when you open the “Links” section you get a red text “Error” message (“Download Links” tab).

Does anybody have any idea why this is happening? Any help will be greatly appreciated!

The share link works like as ussual (Seafile Server ARM Arch) , it should be another issue.I don’t know what it could be the error.

Thank you for answering. I reverted the system back to 6.0.9 and everything works normally again. So it must be some change in 6.1.1 that is causing the problem. I cleared the tmp cache but that didn’t help.

I haven’t installed ffmpeg and the other packages (pillow, moviepy) that are related to the movie thumbnails. They are optional, right?

Maybe updating the Pillow to 4.1.1? We have realized that lower version on Pillow doesn’t work properly but if this is related to your issue, I really don’t know. Maybe you can at least try if you have pillow up to date. How with CentOS, I don’t know.

I didn’t install ffmpeg, pillow and moviepy because we don’t need movie thumbnails. Does 6.1.1 still works OK without ffmpeg/pillow/moviepy? Or they must be installed? In the Seafile server changelog it says it’s optional to install them.

It looks like that the update of Pillow was mandatory to use properly the functionality of change the favicon, a new feature in admin pannel. Since the Pillow has nothing to do with the shared link, I don’t know what to do in your case.

I installed ffmpeg, pillow, moviepy but the problem is still there so they really don’t seem to be connected.

When I try to open the “Links” section in System Admin I get “Page unavailable. Sorry, but the requested page is unavailable due to a server hiccup.”

Maybe the problem is connected with “Increase share link token length to 20 characters” (changelog for 6.1.0 beta) or SHARE_LINK_EMAIL_LANGUAGE (changelog for 6.1.1) as they concern shared links? What do you think?

you should run the upgrade script from 6.0 to 6.1 to update the database.

1 Like

Ok, I will try that and see if the problem is fixed. Thank you for answering. I was just going by the documentation which says that this kind of version jump is considered a minor upgrade.

Daniel, thank you, that seems to have fixed the problem! Should I be concerned that I ran the minor upgrade script before the 6.0 to 6.1 upgrade? Can that cause some mix-ups and problems or it’s OK?

You don’t need worry. Minor upgrade script only update some symbolic links.

OK, thank you for your help, much appreciated!

Same problem developed with Ubuntu 16.04LTS,
Problem immediately solved by running the upgrade script from 6.0 to 6.1, I made the same mistake of running the minor upgrade and it made my life difficult when I tried to access the shared files and folders.

Don’t you guys read the manual? Easier to just ask in the forum and keep us busy? :stuck_out_tongue:
Please suggest what was not clear in the manual so we can correct it to avoid such problems in future.

It is clear and logical that this is not a minor upgrade 6.0.x to 6.1.x. :joy:

Why did you ask that angry way? I did so many upgrades in the past - and I - nearly - always read the readme. But after a while with no chages to that file - or with less urgent changes - some people just don’t see priority 1a in this file. And then it will be just forgotten. It’s a mistake, not bad behavior.

This was not intended to be angry, sorry! – I put the :yum: at the end to show that it was ment ironical.

That is why I want to rewrite the whole manual. The current documentation can be taken for that (mostly copy and past) but has to be put together into a nice order.
If the Seafile team does not allow such thing, I might host in on my own server to start with and post the link here. But actually it should not be an issue for them to spin up a small webserver instance to host such documenation rather than Gitbook.