Cant install Seadrive 1.0.0


#1

Hey guys,
im getting an error while seadrive 1.0.0 installation. First i tried to install 1.0.0 over the existing 0.9.3. Then deinstalled 0.9.3 - reboot - install 1.0.0 = same error.
OS: Windows 10

0-installation-failed

Log file Output:
[2C88:3600][2018-11-20T18:45:16]i371: Updating session, registration key: SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall{f2d7f730-bd18-486b-90a7-6ff8d1b23334}, resume: Active, restart initiated: No, disable resume: No
[2C88:1054][2018-11-20T18:45:18]i305: Verified acquired payload: dokan_clean.exe at path: C:\ProgramData\Package Cache.unverified\dokan_clean.exe, moving to: C:\ProgramData\Package Cache\BB22E879FDEEA11BD4929E54A0B97384398EF23F\dokan-clean.exe.
[2C88:1054][2018-11-20T18:45:18]i304: Verified existing payload: Dokan_x64.msi at path: C:\ProgramData\Package Cache{65A3A964-3DC3-0102-0000-180809151012}v1.2.0.1000\Dokan_x64.msi.
[2C88:1054][2018-11-20T18:45:18]i304: Verified existing payload: SeaDrivePrograms at path: C:\ProgramData\Package Cache{647E11A1-ABEF-49D0-8041-1E9196A86BA7}v1.0.0\seadrive.msi.
[2C88:3600][2018-11-20T18:45:18]i301: Applying execute package: dokan_clean.exe, action: Install, path: C:\ProgramData\Package Cache\BB22E879FDEEA11BD4929E54A0B97384398EF23F\dokan-clean.exe, arguments: ‘“C:\ProgramData\Package Cache\BB22E879FDEEA11BD4929E54A0B97384398EF23F\dokan-clean.exe” -x’
[2C88:3600][2018-11-20T18:45:21]e000: Error 0x80070667: Process returned error: 0x667
[2C88:3600][2018-11-20T18:45:21]e000: Error 0x80070667: Failed to execute EXE package.
[0DA8:2804][2018-11-20T18:45:21]e000: Error 0x80070667: Failed to configure per-machine EXE package.
[0DA8:2804][2018-11-20T18:45:21]i319: Applied execute package: dokan_clean.exe, result: 0x80070667, restart: None
[0DA8:2804][2018-11-20T18:45:21]e000: Error 0x80070667: Failed to execute EXE package.
[2C88:3600][2018-11-20T18:45:21]i351: Removing cached package: dokan_clean.exe, from path: C:\ProgramData\Package Cache\BB22E879FDEEA11BD4929E54A0B97384398EF23F\


#2

What Windows version do you use?


#3

I bet he made the update 1809 … ^^


#4

Windows 10 Version 1803 Build 17134.407


#5

we can be sure now that the problem does not come from your version of windows …


#6

@D_FR Thanks for reporting this. May I ask:

  • Are you installing SeaDrive client on your computer for the first time, or upgrading from an existing installation?
  • Have you ever manually installed other version of dokany in your system?

#7

We prepared a debug script, please download it here:

https://seacloud.cc/f/b4fcd691672c4ae98a16/

How to use it:

  • download the zip archive, and extract the contents to your computer (right click the downloaded zip archive with your mouse -> extract all)
  • double click the “run-this-to-debug.bat” file
  • a console window would pop out and it would do some checks, and print messages as it runs

Please post the content in the console window here, thanks!


#8

same problem as above
applieda debug script

— wow64 —
Found Dokan Library 1.1.0.2000 (x64)
uninstall cmd: MsiExec.exe /X{65A3A964-3DC3-0101-0000-180119092517}

final cmd: “MsiExec.exe” /X{65A3A964-3DC3-0101-0000-180119092517} /quiet
merging 0 and 0
merging 0 and 0


#9

I am having the same issue on all my machines. Windows 10 Pro 1803 build 17134.471.

Installer popup: imgur .com/B0xUWBu
Final error: imgur .com/2QbXpiE


#10

…same issue… but solved by manually removing old dokan library…
After the restart my installation worked !


#11

Same Problem from previous 0.8.6 -

Solved: Upgrade with 0.9.5. first (with auto Windows restart) and then 1.0.0. After restart SeaDrive it has now v1.0.0