Can't login | seafile fresh install via docker-compose

Hi. I just try to launch seafile just to check it out, started via “docker-compose up -d” and it looks like it works, but i can’t login as admin, I see the page but it tells me: “Incorrect email or password”.
I tried to chage it in compose.yml file, but still it tells me the same.
I looked over /opt/seafile-data/logs/var-log directory and have no clue where is the log of app itself.
Can’t see any useful info in these logs.

I didn’t changed anything else, like db password, so i couldn’t break anything.

upd: ok I changed password via script, but the issue still exists, because I reproduced it on another clean linux machine.

Hi, I think I’m experiencing the same issue.
Can you share how you managed to “change the password via script”?

(It’s quite crazy to me that an issue like that seems still not fixed after 6 months!)

Don’t know your setup but I tried just now and it works fine. :thinking:

Anyway, you can create an admin account or change its password as follows:

docker compose exec -it seafile seafile-server-latest/

@Barolo you can find my setup in a dedicated post on this forum. I don’t know why, but I can’t share link in comment, very inconvenient. The post is “Fresh docker install, admin user issue”

(Running the script from inside the container also fails.)