Can't sync with SeaDrive with "denied by cloud-only permission"


I’m Admin (not Owner, don’t know if that makes a difference) of a library on my university server, I can work on it from the web server, I can access it from Seafile client and I can download the library from there, but I’m denied the sync from Seadrive, with the UI message “Syncing is denied by cloud-only permission setting”.
I tried to check that no such permission was set for me by looking at each and every folder of the library (well, maybe not all, as there are a lot of them). But it shouldn’t block me.
The problem happened after I observed a loss of sync, tried one thing or the other, then decided to wipe everything out on my local computer and sync everything back. So now I’m stuck without my data locally.

I tried the workaround mentioned in a similar-looking thread (sorry, can’t put links in my post), namely: purging the program, deleting ~/.seadrive and removing and adding back my user to the library/group.

Any help from the community would be very much appreciated! Thanks in advance

Tech details:
Ubuntu 22.04
Seadrive client version 2.0.28
(don’t know the Seafile server version, but it’s a pro)

log file output:
[seadrive-gui.log] Message repeated multiple times:
[05/02/2024 10:10:40] “Object does not exist at path “/org/freedesktop/NetworkManager/ActiveConnection/12””
[05/02/2024 10:13:16] [api] network error for XXXX/api2/auth/ping/: The specified configuration cannot be used.

[02/05/24 14:24:37] sync-mgr.c(799): Repo ‘XXXX’ sync state transition from ‘get token’ to ‘downloading’.
[02/05/24 14:24:37] http-tx-mgr.c(5130): Download with HTTP sync protocol version 2.
[02/05/24 14:24:37] http-tx-mgr.c(1137): Transfer repo ‘21d5a3eb’: (‘normal’, ‘init’) → (‘normal’, ‘check’)
[02/05/24 14:24:37] http-tx-mgr.c(2587): Bad response code for GET XXXX/seafhttp/repo/21d5a3eb-d38f-4ed4-9011-cf09ab5734c1/permission-check/?op=download&client_id=8734d8667eed1c3db15c41f5c35d842bcd4dec5d&client_name=ordi_pro: 403.
[02/05/24 14:24:37] http-tx-mgr.c(5136): Download permission denied for repo 21d5a3eb on server XXXXX.
[02/05/24 14:24:37] http-tx-mgr.c(1137): Transfer repo ‘21d5a3eb’: (‘normal’, ‘check’) → (‘error’, ‘finished’)
[02/05/24 14:24:37] sync-mgr.c(832): Repo ‘XXXX’ sync state transition from downloading to ‘error’: ‘Do not have permission to sync the library’.

Admin is different from owner. Admin can re-share the library to some one else but is not the owner. The share permissions shouldn’t affect the owner. The specific path that cause problem can be found in the “file sync error” dialog which can be accessed from the tray icon menu.

Hi, thanks for the input. The point is, the share permission issue seems to be a bug with the Seadrive client, since I can download locally the library from the Seafile client: there shouldn’t be an issue.
As long as I remember using the Seadrive client (couple of years), I’ve never seen a single file populated in the “file sync error” dialog, even when the tray-icon was showing some red signal. When I look at the dialog, it’s empty, and the tray-icon is back to a green check-mark when I close it.

You should upgrade the the latest 3.0.x version. In the latest version, more file sync errors will be shown in the dialog.