Can't upload/download files with Android client


#1

Hi guys!

I facing an issue a long time. I can’t download or upload files over the Android client. It always fails with the error upload failed. I don’t see any errors in the logfiles on my server and I don’t know where the logs are located on my phone.

Uploading or downloading over webbrowser or client works fine.

It’s the default config in combination with IIS in use. What could it be?


#3

Really no solution? Maybe my config’s could help you.

Seafile
ccnet.conf: https://pastebin.com/S2SBRrmD
seafile.conf: https://pastebin.com/ZQTAvKs5
seahub_settings.py: https://pastebin.com/L8hXAzbv

IIS
web.conf: https://pastebin.com/HV5ycVvt
SSL: Let’s Encrypt Cert.

Firewall
TCP-Ports: 10001, 13418, 12001, 8082, 8000

Oh sorry, I forgot to say it’s version 6.0.7 on Windows Server 2012 R2.


#4

Hi,

I have the same problem.
After changed the hardware form rpi 2 to rpi 3 and updated the seafile server from 5 to 6.1 I also cannot download files with the Android client.
With the Linux and windows clients I have no problems.
Also downloading on an android phone via a web browser works fine.
Any idea?


#5

I had this problem. I could see the files listed on my phone but could not download/upload them. This was because my server was set up for https rather than http.

If your server is https, make sure you set the SERVICE_URL and FILE_SERVER_ROOT as detailed here: https://manual.seafile.com/deploy/https_with_nginx.html

The easiest way to do this is via the web front end. Go into System Admin > Settings and set the two boxes in the URL section after carefully reading the instructions below them.


#6

@nlong As you could see in my post second from above it’s config’ed like that.


#7

Can you log path from where client trying download the files, it may help find bad setup.


#8

After changing http to https via Admin > Settings I was able to download via the android client again.
After changing the values via Admin > Settings, the values in seahub_settings.py and ccnet.conf was not change.
And also the otherway aroung changing the value in the two conf file did not change the values in Admin->Setting.
Can somebody explain this?
(running 6.2.2 server on rpi)


#9

See first paragraph …

https://manual.seafile.com/config/seahub_settings_py.html


#10

Dear All,

I have deployed seafile server. I am unable to upload files via android client. I can upload/download via we browser both on phone and PC but I can only download via android client. Upload failed error while uploading by android client. Any help is greatly appreciated.


#11

Dear All,

I have noticed that when I use https after that android client failed to upload.

My ccnet.conf

[General]
SERVICE_URL = https://hassan.com
USER_NAME = storage
ID = 633447d0e7d8272c628fcc183d707b5614a97bc3
NAME = storage

[Client]
PORT = 13419

[Database]
ENGINE = mysql
HOST = 127.0.0.1
PORT = 3306
USER = seafile
PASSWD = 1234
DB = ccnet-db
CONNECTION_CHARSET = utf8

My seahub_settings.py

FILE_SERVER_ROOT = ‘***/seafhttp’
ENABLE_SETTINGS_VIA_WEB = False
LOGO_PATH = ‘img/seafile_logo.png’
LOGO_WIDTH = 371
LOGO_HEIGHT = 44
SITE_NAME = ‘hassan.com
SITE_TITLE = ‘hassan-SaaS’

-- coding: utf-8 --

SECRET_KEY = “5!phjw%ba(4cd0r$sik81-e(bceg4(ucl!j8^zaho@0&cz3%”

DATABASES = {
‘default’: {
‘ENGINE’: ‘django.db.backends.mysql’,
‘NAME’: ‘seahub-db’,
‘USER’: ‘seafile’,
‘PASSWORD’: ‘1234’,
‘HOST’: ‘127.0.0.1’,
‘PORT’: ‘3306’
}
}

Upload/download via web browser and phone browser works great but cannot upload via android client


#12

Hi,

that’s a problem with the current version(s) of the android client.

try 2.2.1 you get it here https://github.com/haiwen/seadroid/releases and uploads will work.


#13

Hi, Not sure if to post this here as it’s the same problem:

I can’t upload by android app (2.2.4, from github). From Linux client works.
From android app, I can create folders or delete uploaded files, just upload (also camera upload) doesnt work.

From the upload moment, I get seahub.log error:

[WARNING] django.request:152 get_response Not Found: /api2/events/

seafile.log:

size-sched.c(96): Repo size compute queue size is 0

I upgraded to seafile 6.3.1, wsgi and have django 1.11.15 on a cubietruck running debian 9.5.

Update:
Ooh, so you mean install an older version, not something since 2.1.1. He who can read has an advantage - it now works again, thanks!


#14

Apologies for the necro, but just commenting my solution in case anyone else has this issue.

In my situation, I didn’t have the “FILE_SERVER_ROOT” setting set as the same as “SERVICE_URL”. This is in the admin options on the seafile server