Collabora/Code not working, WOPI not found / unauthorized

I have just updated my seafile server from 8.x to v9.0.4. Now the collabora integration is broken.
At first collabora did not want to start because of some new environment variables in collabora/code:

docker run -d --rm -p 9980:9980 -e "aliasgroup1=seafile\\.mydomain\\.com" -e "server_name=collabora\\.mydomain\\.com" --cap-add MKNOD collabora/code

Trying to open any file with collabora results in 404 of the url

POST
https://collabora.mydomain.com/browser/eb73aa3/cool.html?WOPISrc=https://seafile.mydomain.com/api2/wopi/files/9de7dae237d94e47e978df3511e542b350f57882&ui=de-DE&rs=de-DE

My search in the collabora docs leads to the proxy settings which are outdated in the current seafile documentation.
For all that have the same Problems have a look at Proxy settings — SDK https://sdk.collaboraonline.com/ documentation

After fixing the proxy settings another problem shows up.
Sometimes it is shown something like “document of the last meeting is cleaned up”
The WS-Connection gets closed with the reason:

Connection Closed: 1008 error: cmd=internal kind=unauthorized

Any ideas?

Does nobody knows whats wrong with the authentication?

@daniel.pan @Jonathan

We will check whether Seafile can work with the latest Collabora/Code.

thanks :slight_smile: