CPU iowait / server stops responding while browsing images / generating thumbs

Hello :slight_smile:

I just installed Seafile on my Raspberry Pi 4 (nothing else but SF running, latest Raspbian) and encountered the following problem:

  • browsing images in any mobile app or in the webinterface causes the seafile server to stop responding
  • “iowait” hits 50-100% on the Pi 4
  • need to restart seafile,seahub and nginx then
  • everything goes back to normal -> until s.o. tries to browse images

Browsing files/images via windows explorer is no problem.

The problem seems to be the thumbnail generation.

What we tried:

  • benchmarked the SSD to rule it out (MX500 via USB Interface), performs as expected (4k random read)
  • switched SD Cards (from U1 to U3 and back again)
  • moved thumbnails dir to SSD
  • limited simultaneous connections via nginx config
  • tried different versions of pillow

Still: the moment someone browses images (ios, android, webinterface on wIn 10) the server stops responding and glances shows 50-100 percent of iowait on the cpu. Can’t find anything on the web on this issue. Or we are too dumb to search.

Does anyone have any clue?
Help would be very apprectiated. :slight_smile:

Here’s the solution. It was the SSD. I’m not allowed to post link - why? Search on the raspberry forums for “USB SSD quirk”.

The thread is called:
STICKY: If you have a Raspberry Pi 4 and are getting bad speeds transferring data to/from USB3.0 SSDs