Critical Bug at File Upload via Browser - pro server 6.1.8 - need support

Hi there,

can someone confirm / test this unexpected behavior?
I created 1.982 files with the size of 1kb.
The size doesn’t matter. Uploading was faster only.
Then I uploaded them via browser (Chrome on Win10).
On another client computer I checked the amount of files that were synced.
And guess what? There were not 1982 files. Only 1227 arrived there.
The upload dialog in the right lower corner said: saving…
Longer than 30min I waited.

Ok to make a long story short:
If you are below 399 files the upload via browsers works fine.
In all tested Versions (6.1.4 Pro, 6.0.7, 5.1.11)
Above 600 files no seafile server got the message: Upload completed. (in browser gui)
Even on all different Seafile Versions the Upload with 600 files can’t completed.
Via Seafile client everything works fine.
Sometimes in the Browser Upload window is: Unknown error or Access denied.
In my production setup with pro version i tracked it exactly:

398 files added to upload queue - 398 arrived online - perfect!
399 files added to upload queue- ONLY 365 arrived online - Browser says: saving…

OS and DB and Web Server vary on all of the systems.
Ubuntu 12.04 to 16.04
MySQL till Ubuntu 14.04 later MariaDB
Apache 2.0 to 2.4 or nginx

Production System is Ubuntu 16.04.3 LTS
MySQL -mysql-server-5.7
nginX stable Version 1.12.1
All settings were made and double checked via Seafile Manual.

Maybe someone could help or confirm this.

Thank u.


Why is File Uploading @ 100% and some files were not uploaded?

Don’t upload 1,982 files via the browser.


Maybe there should be a note in the manual: you cannot upload more than 398 files via browser. :yum:

I think this is not a solution but thank you for your very useful support!


Max number of files when user upload file/folder.

Since version 6.0.4


The web browser interface is not designed to handle extreme numbers of files, it’s for one-off uploads and downloads. If you need to do serious syncing, use the local client Windows/Linux/Mac client.

I think here is the answer:

As you can read there is no limitation.
Can we tust daniel.pan? :oP

See answer above, it is possible to increase but browsers are not designed for such high number of files being uploaded.


that is not correct.

Dropbox -> 2000 files
FileCloud -> 2000 files
NextCloud -> 2000 files

All via browser.

Yes it (might) work but there are some disadvantages, for example if your internet connection is bad and gets interrupted, browsers can’t just easily continue while the Seafile client can.

Another thing is speed and file metadata …

I have problem with file upload too.

With client there’s no problem, but with web interface beyond ~600/700 files the browser crash.

The problem is the option in, this option change nothing for me… doesn’t change max file download with client nor by web interface… I set a limit at 500 and upload 600 files with web browser with no problem for example…
It’s a decorative option ? I don’t understand…
(Seafile Pro 6.0.7)


Up ? @daniel.pan

Did you setup max_file_upload on webserver(apache/nginx)?

? Isn’t it a php option only?
There is no option like that in nginx.

Don’t know about NGinx (using apache). But I think there should be some option for that, cause security (DDoS).