CSRF-Problem - Docker + Reverse-Proxy

I am having trouble getting a docker installation of seafile server CE 11 to work behind apache as a reverse proxy.

In the long shot, I will need to migrate our current manual installation of seafile 9 to that, but for now I can’t even get a fresh new install to work.

The installation should be reachable by https://cloud.ourdomain.com. There is an apache webserver on the machine “ourdomain.com” serving several subdomains, including this one. It is accepting requests via HTTPS and reverse-proxying them to That is the current setup, and I thought it should work the same with docker, but it doesn’t.

I have the container up and running with host port 8000 being redirected to container port 80. This works so far that I get a login page, but after that I get a CSRF verification failed error and can’t get past it.

I have read numerous pages here and elsewhere and tried setting SERVICE_URL to https://cloud.ourdomain.com as well as setting CSRF_TRUSTED_ORIGINS=["https://cloud.ourdomain.com"]; I tried changing “proxy_set_header X-Forwarded-Proto https;” as well as “proxy_set_header Host $host:8000;” in the container’s nginx conf, and several combinations of these - none worked.

Is there any definitive guide how to get this setup working?


Hi, had the same error with nginx the way to get it work was to set the header