Docker automatically terminates after a minute within the container /opt/seafile/seafile-server-latest/ stop

Dear Community,

i try to import files from local harddrive with the seafile import script which would be this command:
sudo docker exec -it seafile /opt/seafile/seafile-server-latest/ -p /import/files/ -n 'myFiles' -u user

But to make the import i have to shutdown the seafile server beforehand.

that should not be a huge problem by doing so with:
sudo docker exec -it seafile /opt/seafile/seafile-server-latest/ stop

But there is the problem:
After stoping the seafile server with the script within the container the seafile container terminates itself. That seams to me like a built in mechanism from the seafile docker bootstrap script or something like that.

So i cant even fire up the import job because the container stops every time after around a minute. Is there a way to keep the seafile-container running to run my import job?

i am running the seafile pro docker image according the documentation:
(Install of the docker using the seafile pro registry)
sudo docker run -d --name seafile
-e SEAFILE_ADMIN_EMAIL=admin@mydomaincom
-e SEAFILE_ADMIN_PASSWORD=mysupersecretpasswd
-v /local/seafile_data:/shared
-p 80:80
-p 443:443

That means i am running the seafile-pro-server-6.2.13 docker image.

I am going so far that i am confirming my thesis: I found the responsible script (/scripts/ within the container . The first lines of the script commenting the following:

Starts the seafile/seahub server and watches the controller process. It is
the entrypoint command of the docker container.

Would be really glad if somebody could help me out there. Without the possibility to mass import the files seafile seams to me useless. With those tons of data using the webbrowser for importing would not be a solution either. Last but not least switching to a “bare metal” install without docker is something that i wouldn’t do either.

with best regards and thanks in advance

There is a workaround though:

Edit the script /scripts/

and find the part with


and replace it with (1 week duration):


restart the seafile server and than you are able to stop…

But its a workaround and there should be a true solution