Docker Install - wrong timezone variable name?

We are in the process of buying the professional version but I had to create a new VM to run Seafile because the one we had the CE version on didn’t meet the requirements for the latest Pro version (Ubuntu 16.04 LTS).

So, starting from scratch (Debian 10) I installed Docker and followed these instructions:

I went to customize the Timezone and I changed this line in the docker-compose.yml file:

  - TIME_ZONE=Etc/UTC  # Optional, default is UTC


  - TIME_ZONE=Etc/Australia/Brisbane

When I run docker-compose up The MariaDB and Memcache containers come up but not seafile. This error is reported:

root@fred:/data/seafile# docker logs seafile
*** Running /etc/my_init.d/…
invalid time zone
*** /etc/my_init.d/ failed with status 1

*** Killing all processes…

I solved this by changing it to:

  - TZ="Australia/Brisbane"

Why is this the case?


I don’t know the case but thanks for your post. I had the same problem right now. I used seafile for a long time - but now the first time with docker and with your post i was able to get this problem solved.