Docker pull and docker login not working


#1

I recently pulled the Seafile Pro Image and set up a container sucessfully.

I tried docker pull to check if there is a updated image.
I got this response:

Error response from daemon: manifest for [therealhostname]/seafileltd/seafile-pro:stable not found

so i tried to login again with my credentials and the hostname from the customer center:

Error response from daemon: Get https://[therealhostname]/v2/: unauthorized: authentication required

I tried
docker logout [therealhostname]
and login again, same behaviour.

Is there a known problem with the seafile docker registry?

btw:
OS: debian 9.5
Docker: Docker version 18.06.1-ce, build e68fc7a


#2

It looks like there is some issue with the registry.

Maybe it would be better to just host the images on docker hub or quay.io or gitlab.com.


#3

same issue here.

Any update on this?


#4

@daniel.pan the registry for seafile pro is down. Better host the image at hub.docker.com or quay.io or gitlab.com.


#5

Also having this issue right now. Still no solution it seems.


#6

It will be fixed soon.


#7

Because we want to have some permission control.


#8

You have the same control with both options. You can take the image down whenever you want. Current registry just makes it harder to find the image, harder to use the image and is way less reliable. How should a customer work with that when he doesn’t know whether the registry will be up when he wants to pull the image or not?

The current public credentials to not increase control or security in any way.


#9

The login works again, but the image is only Version 6.2.13.

When will it be updated to the most recent version (6.3.4)?

Greetings, Chris


#10

I think there are some legal issues to put a proprietary software on DockerHub.


#11

hi, do you have an expected date to resolve this?


#12

For proprietary software docker hosts the docker store (https://store.docker.com).
You also have some more control over your uploaded containers than at the docker hub.


#13

According to https://github.com/docker/hub-feedback/issues/1194 it is fine and you can just add your license agreement (e.g. put it in the readme).

Docker Store has the disadvantage that you’re not allowed to offer on docker store and sell apart from it. It is understandable but I don’t think that is what Seafile Ltd. wants.

It could be an option to reach more customers, though.

No matter where it is published the docker image still has many things that need to be improved and there is very few documentation.


#14

I think that is not a real problem.
I use a lot of the Oracle middleware and database images from the docker store at work.
You have to buy the images in the store before you can use them, but thats just a click on the ‘buy’ button, the licensing is done the usual way.


#15

FYI 6.3.4 is now available as I tried again today and it worked.

upgrade was also successful.


#16

Hi,

Can you please shortly describe upgrade procedure when working with docker images?


#17

you can find the documentation here:

https://manual.seafile.com/deploy/deploy_with_docker.html


#18

[therealhostname]/seafileltd/seafile-pro:stable

It’s also worth pointing out that there is no image with the “stable” tag. The image should be [therealhostname]/seafileltd/seafile-pro:latest.


#19

With docker there is no stable tag by definition. latest is just the tag being used when none is specified but by definition it doesn’t say anything about the image provided at the tag.

And it pretty much looks like the registry is broken, again.


#20

same problem here .

tried to login into the repo , and got Error response from daemon: Get https://$registry/v2/: unauthorized: authentication required

both on ubuntu 16.04 + docker 17.03.2-0ubuntu2~16.04.1
and ubuntu 18.04 + 18.06.1~ce~3-0~ubuntu

anyone else is having login trouble?