Does seahub 10.0.x require python > 3.6?

I’ve recently upgraded to 10.0.1 on my seafile server (upgraded/install manually from tar.gz on an openSUSE 15.4 server).

openSUSE has python 3.6.x as it’s default system python3 version. After trying to start seahub, I get the same errors as drmartin posted in comment #8 here: Seafile community edition 10.0 is ready! - #8 by drmartin

Initially I thought to install a newer newer python (I tried python3.9) and manually changed the symbolic link on my system for python3. (from pointing to python3.6 to python3.9) this worked to get seahub to start, but broke other system services that seem to depend upon python 3.6 (since it’s the default version openSUSE expects). OOPS!

I’ve restored the link back to python3.6 and modified -
I’ve changed line 57 (?) “PYTHON=python3” to read “PYTHON=python3.9” in the check_python_executable function. This seems to allow seahub to start under python 3.9 and my system continues to use python 3.6 for everything else.

This experience leaves me with 2 questions:

  • Does Seahub/seafile server 10.0.x purposely require python > 3.6 or is the error drmartin and I have seen a bug ?
  • Is there a better way to override the version of python just for seahub/seafile ?


As written in our release table: Seafile Release Table

10.0 version requires Python 3.8+.

Hi Daniel,
thank you for the confirmation.

Do you know about my 2nd question - is there a better way than what I’ve done to tell seahub to use a different python executable ?

I think your modification is a good one. There is no better way currently.

Thank you for the info!