Download of big (>~4Gb) files usually fails

I’m been using seadrive 1 and 2 both for windows and mac since some years ago, and this issue usually happens but get working by insistence.

When trying to copy big files from seadrive folder to a local one, transfer progress starts but prematurely ends after some time. If I select “download” in the file, the same happens. In logs, the following lines appear:

[03/12/21 07:49:59] sync-mgr.c(697): Repo 'xx' sync state transition from 'committing' to 'synchronized'.
[03/12/21 07:50:46] file-cache-mgr.c(2738): cache size limit is 40000000000
[03/12/21 07:58:10] fuse-ops.c(1362): Failed to read Input/output error.
[03/12/21 07:59:01] file-cache-mgr.c(625): Failed to download file in repo 99...

And a message appears in explorer/finder telling that file can’t be copied

The strange thing is that the appears at different downloading progress each time (seen in transfer window), may remember a network timeout but it’s not the case. Manual downloading from website works, so, when download fails, I usually retry 3-4 times and end downloading by website when keeps failing.

So, it’s not a disastrous failure, but an annoying one, specially for new users not used to this.

1 Like

Looks like your SeaDrive cache size is smaller than the file size and some blocks may be garbage collected before the download finishes because the cache is getting too large.

You should try SeaDrive 2.0 which is easier to find the cause of issue.

I think it’s not the case, cache size is 40Gb (2nd line in log) and clean interval 60 minutes (to allow having extra files for a while)


I’m using mainly 2.0 (2.0.12 under macOS), in fact, that log and issue was generated with 2.0

It doesn’t seem to be the case. The log belongs to 1.0 version. There is no such messages in 2.0 version.

Not really, that comes from 2.0.12 on macOS big sur.

2.0 in macOS just seems a rebranded 1.0, as it hasn’t the main change to windows cloud api, so you are probably ok telling that. Anyway, it’s the latest available version for macOS

I see now. This could be due to downloading the file takes too long. Can you try to use the download menu item in the Finder context menu?

Yes, when copying the file fails, Download in Finder context menu is my next attempt. That sometimes work, sometimes require a number of attempts and other times keeps failing (at different percents), then I go to web, that has always worked for me.

I can understand that copy from seadrive to another folder fails, as there are external app timeouts there, what is annoying for me is that failure (~random) with Download option in Finder context menu, I suppose it’s managed by seadrive, so it should keep trying to download the file, even if network disconnecting or timeouts appear.

You can test 2.0.13 version, which includes improvements to download speed. That may be related to your issue.

Tried 2.0.13 with no failure so far, but being a random failure I can’t be sure. I did also changes in nginx https configuration.
Which results odd is that even using the contextual Download option, a forced download is interrupted without notice and not retried if laptop network changes (wifi change for example). From a final user point of view, I expect the file download to be retried when network connection is resumed.
About speeds, I’ve not noticed differences in 2.0.13 with previous ones, but, as said, I implemented changes in https configuration of nginx, so, the bottleneck could be here.
Have you any (recent) recommended configuration for performance?