Error: Failed to decompress fs object


i’ve the following problem. i cannot sync one of my libraries.

i checked the integrity and seaf-fsck, and the result was:

[05/27/17 14:53:21] fsck.c(595): Running fsck for repo 333fc81a-34b5-4783-9755-2637c7a31ea7.
[05/27/17 14:53:21] fsck.c(422): Checking file system integrity of repo Pictures(333fc81a)...
[05/27/17 15:56:16] fsck.c(659): Fsck finished for repo 333fc81a.

so i tried to export the library with seaf-fsck and then the following error appeared.

[05/27/17 18:24:00] Failed to inflate.
[05/27/17 18:24:00] ../../common/fs-mgr.c(2836): Failed to decompress fs object de526cfac7fdaa92c83673af2b42de87ed34d26f

Can this error be fixed ?

You can try to re-sync the library locally.

So there would be no other option?

If the user has it files not locally are the files in this case lost?

I think his problem is some internal metadata in the client is corrupted. It doesn’t affect the availability of the files. The sync problem can be solved by unsyncing and resyncing.

As far as i can see, he tries to export the files with seaf-fsck on server side?!

And i ask because if this user would have used seadrive, he does not have the files on this computer. And i think there will be more users with seadrive in the future…

Correct, i don’t have the files on my computer, that’s why i want to download them (via client or fsck doesn’t matter.)

Is this library encrypted or old library created before 3.0 version?

The library is not encrypted and created with Version 5.x (current version is 6.0.12)

Can you check the file size of storage/fs/333fc81a-34b5-4783-9755-2637c7a31ea7/de/526cfac7fdaa92c83673af2b42de87ed34d26f?

Hi Jonathan, here it is:

/var/lib/seafile/data # ls -lha storage/fs/333fc81a-34b5-4783-9755-2637c7a31ea7/de/526cfac7fdaa92c83673af2b42de87ed34d26f
-rw------- 1 seafile seafile 1,1K Mär 19  2016 storage/fs/333fc81a-34b5-4783-9755-2637c7a31ea7/de/526cfac7fdaa92c83673af2b42de87ed34d26f

/var/lib/seafile/data # du -h storage/fs/333fc81a-34b5-4783-9755-2637c7a31ea7/de/526cfac7fdaa92c83673af2b42de87ed34d26f
4,0K	storage/fs/333fc81a-34b5-4783-9755-2637c7a31ea7/de/526cfac7fdaa92c83673af2b42de87ed34d26f

Actually I can’t explain your problem well. Is it possible that your libraries was changed between you run fsck and the export command?

This happened to me today also with ALL of my clients after upgrading one PC seadrive to the latest version 0.7, the error of “Failed to decompress fs object”

i ran a FSCK and it came up clean before resyncing but it has been okay since, not sure whats up

Im on version 6.0.13