Error:Seahub failed to start - RPI 7.1.5

Apologies for yet another thread about seahub not starting, but I’ve looked through all the others and none of the proposed solutions have worked for me.

This is a new installation using the RPI 7.1.5 version on Ubuntu 18.04 w/ python 3.6. I followed the instructions for installing python dependencies and such, I can start seafile itself with no problem but cannot start seahub no matter what I try, and I’m unable to get any sort of helpful logging or error output. Note that the first time I ran it I was able to create an admin account, but it then failed and every subsequent attempt to start it has failed with the same output.

seafile ./*latest/seahub.sh start

LC_ALL is not set in ENV, set to en_US.UTF-8
Starting seahub at port 8000 ...
Error:Seahub failed to start.
Please try to run "./seahub.sh start" again

Running start-fastcgi gives me the error Unknown command: 'runfcgi'.

Has any dev read our messages about rpi support ?

Hello,

I’m not an expert and I meet some problem with Seafile but have you try to edit conf/gunicorn.conf.py and change daemon = True to daemon = False in order to have the log when you start seahub?

I think you will have more informations to diagnose :slight_smile:

Thank you so much! After doing that, I got the error message Error: /var/www/seafile/pids doesn't exist. Can't create pidfile. The problem was that gunicorn.conf was referencing that folder, which doesn’t exist as I moved seafile to /opt/seafile. Changing that value allows seahub to start, finally! I wish this daemon config option were more clearly documented in the the “When scripts fail” section of the docs.

1 Like