Error:Seahub failed to start. Try again

Hello everyone,

I am not new to Seafile and have like 11 servers that run without any issues for more then 6 years.
Because one of the servers is running out of storages, I want to replace it with a new server with bigger storage.
The new server is in testing mode with the following base layout.

  • Ubuntu 18.04 LTS
  • Database Server MariaDB (localhost)
  • Seafile version 7.1.4
  • Python Tools (installed)
  • Nginx (NOT installed yet)

The installation has ended successfully without errors. (
Starting, success no problem.

Starting, will not start !!!

On normal start I get a error:

/srv/seafile/seafile-server-latest# ./ start
Starting seahub at port 8000 ...
Error:Seahub failed to start.
Please try to run "./ start" again

On fastcgi start I get a error: (yes I know fastcgi is not supported anymore)

/srv/seafile/seafile-server-latest# ./ start-fastcgi
Starting seahub (fastcgi) at ...
Traceback (most recent call last):
  File "/srv/seafile/seafile-server-7.1.4/seahub/", line 10, in <module>
  File "/srv/seafile/seafile-server-7.1.4/seahub/thirdpart/django/core/management/", line 364, in execute_from_command_line
  File "/srv/seafile/seafile-server-7.1.4/seahub/thirdpart/django/core/management/", line 338, in execute
  File "/srv/seafile/seafile-server-7.1.4/seahub/thirdpart/django/", line 27, in setup
  File "/srv/seafile/seafile-server-7.1.4/seahub/thirdpart/django/apps/", line 85, in populate
    app_config = AppConfig.create(entry)
  File "/srv/seafile/seafile-server-7.1.4/seahub/thirdpart/django/apps/", line 94, in create
    module = import_module(entry)
  File "/usr/lib/python3.6/importlib/", line 126, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "<frozen importlib._bootstrap>", line 994, in _gcd_import
  File "<frozen importlib._bootstrap>", line 971, in _find_and_load
  File "<frozen importlib._bootstrap>", line 953, in _find_and_load_unlocked
ModuleNotFoundError: No module named 'captcha'
Error:Seahub failed to start.

Over the past 2 days, I have installed the server over and over with different layouts but the problem remains.
I also tried to install the captcha MODULE but the problem remains.
And the Seahub.LOG is empty.

Is there anyone for help?

Did you install the required dependencies for 7.1.*?

Axstet thanks for your reply

That was missing yes!!!
Now Seahub starts, but the web GUI is not showing, also Seafile client MacOS connect is not working (connection refused)

seahub.LOG still empty


Thanks for your help, the blanco web GUI was the problem of Nginx the media location was wrong.
So everything works now.
ones again thanks for your help :muscle: