Error upgrading from 7.0.19 to 7.1.x: No module named 'saml2'

Hi,

When upgrading from seafile-pro-server-7.0.19 to seafile-pro-server-7.1.x (I tried 7.1.5 and 7.1.18) I get:

./upgrade/upgrade_7.0_7.1.sh

renaming the gunicorn.conf to gunicorn.conf.py …

Done

Updating seafile/seahub database …

[ERROR] Failed to import seahub_settings.py: No module named ‘saml2’

Failed to upgrade your database

saml libraries are installed:

pip3 install python3-saml
Requirement already satisfied: python3-saml in /usr/local/lib/python3.6/dist-packages
Requirement already satisfied: xmlsec>=1.0.5 in /usr/local/lib/python3.6/dist-packages (from python3-saml)
Requirement already satisfied: isodate>=0.5.0 in /usr/local/lib/python3.6/dist-packages (from python3-saml
)
Requirement already satisfied: lxml>=3.3.5 in /usr/local/lib/python3.6/dist-packages (from python3-saml)
Requirement already satisfied: defusedxml==0.6.0 in /usr/local/lib/python3.6/dist-packages (from python3-s
aml)
Requirement already satisfied: six in /usr/lib/python3/dist-packages (from isodate>=0.5.0->python3-saml)

I followed instructions from upgrade/upgrade_notes_for_7.1.x/ documentation

Environment description:

  • OS: Ubuntu 18
  • Current Seafile version: seafile-pro-server-7.0.19

Any idea to fix this?

Thanks!

Running:

pip3 install pysaml2
fixed it

The whole command sequence was:

apt-get install libxml2-dev libxmlsec1-dev libxmlsec1-openssl
apt install python3-pip

pip3 install python3-saml
pip3 install --timeout=3600 Pillow pylibmc captcha jinja2 sqlalchemy==1.3.8 django-pylibmc
django-simple-captcha python3-ldap
pip3 install pysaml2