Error when starting Seafile Client


#1

I have a self-hosted instance. The Seafile client works on other computers in my environment. This computer is running Windows 10 Pro 10.0.17134.

When starting the Seafile client I get the error pop-up, “Seafile client failed to initialize.” Output from the logs are below.

applet.log
[01/09/19 09:31:49]read id from id file
[01/09/19 09:31:49]starting seaf-daemon: ("-c", “C:/Users/CP/ccnet”, “-d”, “D:/Seafile/seafile-data”, “-w”, “D:/Seafile”)
[01/09/19 09:34:46]seafile rpc is not ready after 16 retry, abort
[01/09/19 09:36:22]Seafile client failed to initialize
[01/09/19 09:36:22][Daemon Mgr] stopping seafile daemon
[01/09/19 09:36:22]Seafile daemon process exited normally with code 62097

seafile.log
[01/09/19 09:31:49] seaf-daemon.c(491): starting seafile client 6.2.9
[01/09/19 09:31:49] seaf-daemon.c(493): seafile source code version dd49e4bc26623162c8b7d5ae29c17927d3bf6718
[01/09/19 09:31:49] seafile-session.c(382): client id = 3e6e47081f0e523e5a936f96b9079ea6f872128f, client_name = unknown
[01/09/19 09:31:49] seaf-daemon.c(518): rpc server started.

Help!


#2

same problem here, but it works if i start a second deamon. Wierd is i have to pcs with same windows version (updates etc) only difference is the processor (i7 4770 and r5 1600 (AMD not working)). After the installation the window vanished and i cant open it to log in.


#3

This is the same problem https://github.com/haiwen/seafile/issues/2146

Which anti virus software do you use?


#4

on both systems the windows defender. The Thing is as i installed windows it worked on my amd system, after a month windows installed an update and i did some bios updates and driver updates,after that it broke.


#5

I tried what @Survive did and started a second instance of seaf-daemon in a window and the client worked. Could communication over named pipes to the seaf-daemon that is instantiated by the client initially be blocked for some reason?


#6

Sorry, to answer your previous question @marcusm, I am running ClamWin anti-virus and have Windows defender disabled. The other PC where the client works also has ClamWin installed.


#7

We had computers with and without Defender or another Anti Virus Software installed, so i think the problem is not related to anti virus. @Jonathan


#8

Hello,
Is there any news on this problem ?
I have the same issue with a customer and no solution so far…
Thanks,


#9

Version 6.2.11 seems to have solved the problem.
We had the problem on two Windows 10 machines, both of them are working now.
Good !


#10

Thanks for the info, we’ll test it.


#11

I ended up reformatting my operating system drive and reinstalling with the latest build of Windows 10 to resolve a different problem. After doing that I have no issues. That’s obviously not a viable resolution strategy, but unfortunately I won’t be much help to continue troubleshooting. It is reassuring to know that if I didn’t reformat, version 6.2.11 may have resolved the problem or may in the future if the problem reoccurs.

Thanks everyone.


#12

version 6.2.11 does not fix the issue, but installing a new windows help aswell in 6.2.9. So its still unknown what causes this problem.


#13

I had the same problem on two PCs with freshly installed 6.2.11 today… when starting the seaf-daemon.exe by hand the client will start and you can use it normally, but then you have a console window open all the time.


#14

Do you have Acronis Active Protection installed and running? I had the same problem, almost gave up. Then I found out you have to manually add seaf-daemon.exe to the list of trusted apps. This was really hard to find out because usually Avtive Protection gives a warning message when a possibly harmful app is found - not in this case.

Now Seafile client 6.2.11 is running fine!

Update: To clarify, Acronis Active Protection is a ransom-protection tool. The described problem might also apply to other apps of that kind.