Failed to manual upload via webgui/client/android


#1

hello guys,

i have just started to implement and using this Seafile server (community version).
the webpage all working fine, but when i tried to manually upload file(s) into my own Seafile server hosted in VPS but failed, NETWORK ERROR. all these happened using webgui, windows client and android apps.
But the thing is, i can sync my local folder into Seafile server with no issue at all.

i have set correctly for the following settings in both ccnet.conf and seaub_settings.py respectively,
SERVICE_URL = ‘http://my-domain.net
FILE_SERVER_ROOT = ‘http://my-domain.net/seafhttp

for all Seafile gurus out there, need your help.
thank you very much!! :bowing_man:


#2

DUPLICATE Please search trough forum before opening a thread:


Your location for configuring is wrong :wink:


#3

hi bionade24,

Are you referring to the admin panel setting? i have set it accordingly.

same location setting in ccnet.conf and seahub_settings.py:
SERVICE_URL = ‘http://www.my-domain.net
FILE_SERVER_ROOT = ‘http://www.my-domain.net/seafhttp’


#4

Do you really use http without TLS encryption? This is a huge security risk.


#5

I know the risk but i still don’t have the idea how to implement the TLS encryption, even though have searched through Google.
Anyway, for the said location is it set correctly?
Sorry as I’m still noobie in Seafile and linux system.


#6

Seems all correct and like you configured something wrong either in your seahub_settings.py or in your web server’s config.

Encryption is essential i you use it outside your home network. You should find plenty of maunal, but I believe the Seafile community manual is the best one. There is also an official manual, but it’s often outdated and not that well.


#7

Below is my seahub_settings.py configuration, is it correct?
snap1

Will run through the link, thanks alot!!


#8

I think your problem is your nginx/apache config. Just check update your setup to https and if there are issues after this, I’ll help you.


#9

Check your DNS settings, and see if you can add WWW.
I run my server on a dyndns domain, and had a very similar problem.
Beside my to ‘myserver.mydomain’ I had to add ‘www.myserver.mydomain’ as an alias.
For some reason webui looks for stuff on ‘www.’ prefixed server name. If DNSQuery fails for that, some functions won’t work, including upload.