Failed to sync seafile database - FYI


I tested clean installation of Seafile server version 7.0.2 and I obtain error:
Failed to sync seafile database
if I change default path from /opt/seafile-server/seafile-data to /opt/seafile-server/data

This is evidently bug…

I got the same error installing 7.0.4 but I used /media/pi/Seafile/data. The installation was made in /media/pi/Seafile/system. Seafile is an ext4 external usb disk. If i use the default data path (/media/pi/Seafile/seafile-data), no problem.

I got the same problem. I also think it is a bug. At line 695 in, the var seafile_db(the path of seafile.db) is ${TOPDIR}/seafile-data/seafile.db, it is the default path, but the seafile-data in default path is not create, so the sqlite3 can’t make the database file, and the installation failed.

Hi. has this been resolved yet?

I got the same problem too. But I solved it easily just after seeing your comment. I think ${TOPDIR} is just the dir that has .sh file(?). I just moved installation dir from /home/myid/haiwen/seafile-server-7.0.5 to /mnt/hdd2/nas/seafile(your hdd path). It worked perfectly.

I ran into this same problem when setting up seafile-server 8.0.3. As suggested above, when I reverted the line in the setup script to
and then re-ran , everything then installed correctly and I was able to start the server.