Failed to upload file: Internal Server Error

I am running Seafile client 6.0.4 with a V6 server. I am trying to upload a 3.2 GB file through the cloud file browser.

I have this error in the client logs:

[14.03.2017 13:11:35]request failed for https://<server>/seafhttp/upload-api/332025dc-fa08-46a7-96b8-40ffaa794d93: status code 500

[14.03.2017 13:11:48]Failed to upload file: Internal Server Error

Any ideas?

maybe this will help for uploading large file:

Tip for uploading very large files (> 4GB): By default Nginx will buffer large request bodies in temp files. After the body is completely received, Nginx will send the body to the upstream server (seaf-server in our case). But it seems when the file size is very large, the buffering mechanism dosen’t work well. It may stop proxying the body in the middle. So if you want to support file uploads larger than 4GB, we suggest to install Nginx version >= 1.8.0 and add the following options to Nginx config file:+

    location /seafhttp {
        ... ...
        proxy_request_buffering off;

@lian Thanks, i saw that in the manual. I already have it set:

        location /seafhttp {
            rewrite ^/seafhttp(.*)$ $1 break;
            client_max_body_size 0;
            proxy_connect_timeout  36000s;
            proxy_read_timeout  36000s;
            proxy_send_timeout  36000s;
            proxy_request_buffering off;
            send_timeout  36000s;

Strangely enough, doing the same upload from home worked fine. It failed at work.