Finder Extension SeaFile doesn't work under MacOS Sonoma

Hi everybody,

I’ve been using Seafile for a long time. I’ve always had problems with the synchronization status being displayed in the Finder.
But since MacOS Sonoma version 14.3 it stopped working.

I de/re-activated it in the app: no success.

I have de/re-activated it in the MacOS settings under “Finder/Extensions”: no success.

I uninstalled Seafile in the current version 9.0.4 (using AppCleaner) and reinstalled it with a new .dmg (same version): no success.

I have combined everything with restarting the MacBook (MBP Pro 13 inch, M1 2020) for several times: no success.

The only exception is the “Save as” dialog: The green dots are (sometimes) displayed in the Finder.

What can I do to make it work again? I use this every day and it is very important to me.

Thank you in advance for your help.

I just setup Seafile 9.0.4 under Sonoma 14.3 on Seafile CE 11.0.5 but it’s not completely healthy. I’m also seeing problems with SeaDrive under Sonoma and Ventura (that share a login).

The process I went through is very similar to what you describe: I completely uninstalled the previous Seafile 9.0.4 using a utility similar to your own; I renamed the user’s previous Seafile folder (Seafile_bak); restarted Seafile and completed the sign-in process; setup a new Seafile folder as requested; copied back user files and allowed sync; checked results against the web login. I might be advantageous to un-sync all folders prior to un/re-installing the service.

I see the Finder icons but have not checked for them in Open/Save dialogs.

In the Seafile application menu, however, I only see a spinner in the Main window where the Libraries and Shares should be listed. This just happened. I did see them previously.

I hope this helps.

1 Like

Hello, quick question about this but generally does the sync client run under Sonoma 14.3?


Yes, Seafile Sync Client 9.0.4 appears to be running under macOS Sonoma 14.3.1.

It is fiddly, however, and you will likely have to do a clean install (see above) before it connects properly.

1 Like

Thanks for youre feedback

Hi @mercury,

thanks for your reply. I tried your instructions once…with one exception: I didn’t delete the synchronized libraries (yet) and completely re-synchronized them…but in the end, this half solution didn’t work for me.

So maybe everything from SeaFile has to be deleted locally (also the hidden directories, like “.seafile-data”), delete the profile properly and then set up everything again… that was too much for 70 GB sync data…

But (unfortunately or fortunately) it suddenly fixed itself on its own yesterday. All the green overly icons in Finder are back.

That’s certainly no help with people with the same phenomenon. Sorry to say. As soon as I have new information, I’ll be happy to share it.

Best, Chris


I am currently running Sonoma 14.3.0.
I have skipped the 14.3.1 update as it has suddenly recovered.

However, I can’t say why it’s always so fiddly after every restart/update…I suspect the problem is with SeaFile, as I have other apps with a Finder extension for overlay icons, which work without any problems.

Best regards

I am glad to hear of your eventual success but a couple questions remain:

  1. Will the “fix” remain in place? Please report back if things change for you.

  2. What is it exactly that restored the Finder icons? The clean install is very broad brush as you suggest and it’s likely that it’s only one or two wayward files that have to be reset, but which ones?

Good luck moving forward.

1 Like

Hello everyone,

I want to share a little update with you.

Over the past few days, I have been avoiding any reboots. I have also not installed any MacOS updates (these change the system and usually require a restart). So I’m still on Sonoma 14.3.0.

It lasted a long time, until today the Finder extension no longer showed any green checkmarks.

My work-around then looked like this:

  • SeaFile Client ran unchanged
  • Terminated the “WindowServer” process with “End immediately” in “Activity Monitor”
  • Logged in normally in the login screen and then it worked again.

There are 3 processes in the “Activity Monitor”:

  • Seafile
  • seaf-daemon
  • Seafile FinderSync

Maybe it will help you. It helped me (at least today).
Best regards

There’s a related post HERE by @Jonathan on the use of the Apple File Provider icons with SeaDrive. You might want to take a look.

Thanks, @mercury ,

I’ve looked into it. But I think it is not really the same, because I’m using “SeaFile Client”, while @Jonathan is referring to SeaDrive. Their concept is way different to each other to my understanding.

More other, I’m not expecting these cloud-icons, like in Jonathans post, but more these green/orange/red checkmarks (see picture below).

Even though, his solution can’t contribute to my situation here, in my point of view.

Best, Chris