Fresh Install, iOS Photo Sync Not Working


#1

In the settings it sometimes shows “1867 photos remain” and other times shows “all photos synced”.

Auto Upload is on
Upload Videos is on
WiFi only is on
Background upload is on
Upload destination is selected (fresh library)

Tried restarting the app, restarting the phone, taking permission away and giving it again in the iOS privacy settings. Does anyone have this working?


#2

Upload generally works?


#3

Upload from my desktop works great. The issue is only with the photo upload from the iOS app it seems.


#4

I guess you mean the client.
What about the WebUI and uploading Data from iPhone?


#5

I tried manual upload on some photos just now, that doesn’t work either. It gets stuck on “waiting to upload” . I also tried making a brand new library and uploading there, that gives the same problem.


#6

good morning together

I have the same problem. The system is secured by a ssl certificate but accept invalid certificates is enabled. Nginx and seafile error logs give me no hint. Up- and Download with Windows/ Linux Clients and web interface are working fine.
Is there any problem with actual iOS version? I have iOS-Version 12.1.2 and seafile app 2.8.1
Something weird too: download via clients seems working but file can not displayed on the phone. If I download an OO file and send it to OO viewer it asks me for activating javascript and asks for username and password from my seafile account. But it is not possible to type in something.

many thanks


#7

Please post your seahub.log


#8
[01/03/19 12:02:35] http-server.c(173): fileserver: worker_threads = 10
[01/03/19 12:02:35] http-server.c(188): fileserver: fixed_block_size = 8388608
[01/03/19 12:02:35] http-server.c(203): fileserver: web_token_expire_time = 3600
[01/03/19 12:02:35] http-server.c(218): fileserver: max_indexing_threads = 1
[01/03/19 12:02:35] http-server.c(233): fileserver: max_index_processing_threads= 3
[01/03/2019 12:02:35 PM] ../common/mq-mgr.c(54): [mq client] mq cilent is started
[01/03/2019 12:02:36 PM] size-sched.c(96): Repo size compute queue size is 0
[01/03/2019 12:07:36 PM] size-sched.c(96): Repo size compute queue size is 0
[01/03/2019 12:12:36 PM] size-sched.c(96): Repo size compute queue size is 0
[01/03/2019 12:17:36 PM] size-sched.c(96): Repo size compute queue size is 0
[01/03/2019 12:22:36 PM] size-sched.c(96): Repo size compute queue size is 0
[01/03/2019 12:27:36 PM] size-sched.c(96): Repo size compute queue size is 0
[01/03/2019 12:32:36 PM] size-sched.c(96): Repo size compute queue size is 0
[01/03/2019 12:37:36 PM] size-sched.c(96): Repo size compute queue size is 0
[01/03/2019 12:42:36 PM] size-sched.c(96): Repo size compute queue size is 0
[01/03/2019 12:47:36 PM] size-sched.c(96): Repo size compute queue size is 0
[01/03/2019 12:52:36 PM] size-sched.c(96): Repo size compute queue size is 0
[01/03/2019 12:57:36 PM] size-sched.c(96): Repo size compute queue size is 0
[01/03/2019 01:02:36 PM] size-sched.c(96): Repo size compute queue size is 0
[01/03/2019 01:07:36 PM] size-sched.c(96): Repo size compute queue size is 0
[01/03/19 13:10:19] http-server.c(173): fileserver: worker_threads = 10
[01/03/19 13:10:19] http-server.c(188): fileserver: fixed_block_size = 8388608
[01/03/19 13:10:19] http-server.c(203): fileserver: web_token_expire_time = 3600
[01/03/19 13:10:19] http-server.c(218): fileserver: max_indexing_threads = 1
[01/03/19 13:10:19] http-server.c(233): fileserver: max_index_processing_threads= 3
[01/03/2019 01:10:19 PM] ../common/mq-mgr.c(54): [mq client] mq cilent is started
[01/03/2019 01:10:20 PM] size-sched.c(96): Repo size compute queue size is 0
[01/03/19 13:13:56] http-server.c(173): fileserver: worker_threads = 10
[01/03/19 13:13:56] http-server.c(188): fileserver: fixed_block_size = 8388608
[01/03/19 13:13:56] http-server.c(203): fileserver: web_token_expire_time = 3600
[01/03/19 13:13:56] http-server.c(218): fileserver: max_indexing_threads = 1
[01/03/19 13:13:56] http-server.c(233): fileserver: max_index_processing_threads= 3
[01/03/2019 01:13:56 PM] ../common/mq-mgr.c(54): [mq client] mq cilent is started
[01/03/2019 01:13:57 PM] size-sched.c(96): Repo size compute queue size is 0
[01/03/2019 01:18:57 PM] size-sched.c(96): Repo size compute queue size is 0
[01/03/2019 01:23:57 PM] size-sched.c(96): Repo size compute queue size is 0
[01/03/2019 01:28:57 PM] size-sched.c(96): Repo size compute queue size is 0
[01/03/2019 01:33:57 PM] size-sched.c(96): Repo size compute queue size is 0
[01/03/2019 01:38:57 PM] size-sched.c(96): Repo size compute queue size is 0
[01/03/2019 01:43:57 PM] size-sched.c(96): Repo size compute queue size is 0

last log entry continues every 5m even up until today. I’ve retracted these dupes for brevity
[01/10/2019 02:14:04 AM] size-sched.c(96): Repo size compute queue size is 0


#9

@bionade24 any other info that would be helpful?


#10

You can access the WebUI?


#11

Yes. (Ignore this for 8 character minimum)


#12

And you can upload something with the web browser in your mobile phone?


#13

Hi guys,

I have the same issue. Latest seafile version on with the windows client any sync operation works great.
Uploading images from my iphone stops after ca. 80 images. remaining 3000 images.
When i switch auto upload on / off it starts uploading from new.
Have the newest iOS App.

Please fix this bug please guys.

B,R.
Sirus


#14

No, I get a network error. Actually, on the web client via desktop too (of course)

"main.3d2d5df25238.js:135 Mixed Content: The page at 'https://[redacted]/#my-libs/lib/bc736ec4-a3cb-440c-8e11-4b560378e638/' was loaded over HTTPS, but requested an insecure XMLHttpRequest endpoint 'http://[redacted]/seafhttp/upload-aj/95bbcafe-f912-4f1e-8137-aea22369281a'. This request has been blocked; the content must be served over HTTPS."

BTW, using the docker version on the server with lets encrypt enabled and I don’t have the protocol specified in the SEAFILE_SERVER_HOSTNAME setting, just the hostname…

seafileltd/seafile latest bfae74570972 3 months ago 923MB

The content warning only happens on upload (don’t see any on page loads)


#15

Did you configured SERVICE_URL and FILE_SERVER_ROOT correctly? You can find it in the WebUI under System Admindistration -> Preferences. Should be https://example.com and https://example.com/seafhttp


#16

Bingo. That was it. They were both http. Perhaps they should default to https when the letsencrypt setting is set to true? I’ve opened a GH issue: (can’t include links :frowning: ) github[dot]com/haiwen/seafile/issues/2163

Edit: I bet lots of ppl are running into this issue as the docker instructions don’t mention those settings and have lets encrypt enabled: manual.seafile[dot]com/deploy/deploy_with_docker.html


#17

They don’t even care about their docker CE container, the container has design failures and security risks. In the Commuity Manual good sefile container images are listed. But check them first, they should be now on version 6.3.4