Help with upgrading to 6.2.2 on pi from 6.1.1

I am using the raspberry pi seafile with rasbpian. I am currently on 6.1.1. When I try to run the upgrade script to upgrade from 6.1 to 6.2, I get “/home/seafile/cloud/seafile-server-6.2.2/ccnet/seafile.ini not found. Now quit”

Did you check that file exists?

It does exist but not in that directory. It shouldn’t be there since that is the directory where I downloaded the file for the new server version. My ccnet folder is in /home/seafile/cloud.

Read manual. You have to have seafile folder same as before. So I guess You had it at /home/seafile/cloud/

You have to extract server in this folder.

This is example from manual

   -- seafile-server-6.1.1
   -- seafile-server-6.2.2
   -- ccnet
   -- seafile-data

Thank you, that resolved the issue. There was one folder too many. The upgrade worked but now I cannot access the server via SSL. I get a 404 not found error. I can access the server via http://ipaddress:8000. If I just enter the internal IP address on my browser I get the nginx page showing that it is working properly. Below is my nginx configuration.

server {
listen 443;
ssl on;
ssl_protocols TLSv1.1 TLSv1.2;
ssl_certificate /etc/letsencrypt/live/$
ssl_certificate_key /etc/letsencrypt/live/$
server_name seafilepi;
error_page 497 https://$host:$server_port$request_uri;

    client_max_body_size 0;

    location / {

  proxy_set_header   Host $host;
  proxy_set_header   X-Real-IP $remote_addr;
  proxy_set_header   X-Forwarded-For $proxy_add_x_forwarded_for;
  proxy_set_header   X-Forwarded-Host $server_name;
  proxy_http_version 1.1;

if you use http2 or you get errors in nginx like connection refused … HTTP$

  proxy_read_timeout  1200s;

 # used for view/edit offic

        access_log /var/log/nginx/seahub.access.log;
        error_log /var/log/nginx/seahub.error.log;

client_max_body_size 0;


    location /seafhttp {
        rewrite ^/seafhttp(.*)$ $1 break;
        client_max_body_size 0;

        proxy_connect_timeout  36000s;
        proxy_read_timeout  36000s;
        proxy_send_timeout  36000s;
        send_timeout  36000s;
        proxy_http_version 1.1;


        location /media {
        root /home/seafile/cloud/seafile-server-latest/seahub;
        # include /etc/nginx/mime.types; # <--- UNCOMMENT THIS IF CSS FILES AREN'T LOADED

Try to change proxy_set_header Host $host; to this:

proxy_set_header   Host $host:8000;

And did you follow manual to upgrade on 6.2.2 where is default WSGI instead of FAST-CGI(there is different nginx configuration)? I don’t know alot about NGinx.

Thank you for your assistance. I copied the configuration from the nginx notes from the new version. I tried that to put port 8000 on the line you gave me but it didn’t work. I then tried using the SSL port 443 and that has fixed the issue and is working properly now.