Hostname resolving through proxy

Hi guys,

I don’t know why is it missing or maybe you have to configure this in some odd place but is it possible to add a simple option in the Parameters > Network > Proxy section so Seafile can force the hostname resolving to happen through the SOCKS proxy if you specify one? That would help a lot.

Thanks for your help!

I also have the problem, that the seafile-client cannot connect through socks5 proxy to the server.
It is working somehow of you play with the applet and switch between the settings.
I was trying:
export ALL_PROXY=“socks5h://”
the little “h” make sure that the hostname get resolved through the proxy. It works fine with command line curl.

I assume that the ALL_PROXY env does not play any role by the seafile-deamon. I am looking to a setting in ~/.ccnet/ccnet.conf