How to change cache location when SeaDrive client won't launch

Hi!

I’ve messed up the SeaDrive client and could need some help to understand how to fix it.

I tried changing the location of the cache directory to an external drive (long story…), and unfortunately now upon launching the SeaDrive client, it quits unexpectedly, every time. I’ve tried deleting and reinstalling the client, but it seems to have saved the settings somewhere. So my question is, does anyone know where these settings are stored, so I can change the location of the cache directory manually?

Edit: Forgot to mention, I’m on macOS. Have tried to delete all related files I could find in /Library and ~/Library, but nothing helps.

Grab AppCleaner (https://freemacsoft.net) and then install using that, its gets all the detritus that would otherwise be left around… potentially like this,

Thanks for the input!! I tried that, but even that didn’t work. It still quits unexpectedly upon launch, and I can see that it creates the cache directory on the external drive upon launch. This is weird!

Intreresting - that uninstaller has done me well. sp far Sorry I wasn’t any further help.

1 Like

You can try below command to clean up the settings of SeaDrive client:

defaults delete ~/Library/Preferences/com.seafile.Seafile\ Drive\ Client.plist