How to Configure SSL on IIS 10

I am really struggling with getting SSL working on a Windows installation using IIS version 10.

I have found numerous articles online that outline how to do it using IIS proxy and rewrite rules. All the articles are slightly different and none of them work in the end.

I have the basic installation working and I have it configured using my custom host/domain name on the standard port of 8000.

Can anyone point me to a correct set of instructions or article? I have found nothing official from SeaFile on the website. Thanks!

-Brian

Maybe this helps:

https://www.weavweb.net/2015/06/07/seafile-https-sync-on-windows-server-2012r2-step-by-step/

Iā€™d still recommend to have a look into the Linux version. The windows release cicle is slow and the performance is somewhat different. :slight_smile:

Either change to Linux you can run it in Hyper-v or install nginx and use that instead of IISz

1 Like

Modify the settings of ccnet.conf and seahub_settings.py to:
https://manual.seafile.com/deploy/https_with_nginx.html

configure iis to listen on port 443 and add the following rules

<rule name="fileserver" stopProcessing="true">
	<match url="seafhttp/(.*)" />
	<conditions	logicalGrouping="MatchAll" trackAllCaptures="false" >
	<add input="{HTTP_HOST}" pattern="seafile.example.com" />
	</conditions>
	<action type="Rewrite" url="http://localhost:8082/{R:1}" appendQueryString="true" logRewrittenUrl="true" />
</rule>
<rule name="seahub" enabled="true" stopProcessing="true">
	<match url="(.*)" />
	<conditions	logicalGrouping="MatchAll" trackAllCaptures="false" >
	<add input="{HTTP_HOST}" pattern="seafile.example.com" />
	</conditions>
	<action type="Rewrite" url="http://localhost:8000/{R:1}" appendQueryString="true" logRewrittenUrl="true" />
</rule>