Install guide on mac is not uptodate

I’m following this guide to install seafile on mac

I’m at this step now :

execute the building script:


The problem is this file doesn’t exist anymore. I guess it’s ./scripts/build/ instead

So I’m running ./scripts/build/ and I got

Traceback (most recent call last):
  File "./scripts/build/", line 28, in <module>
    from fabric.api import execute, env, settings, run as fabric_run
ImportError: No module named api

I solved it by installing fabric version 1 with

pip install ‘fabric<2.0’

( should be added to the doc )

Now the script ask me for a lot of parameter and I have no clue of what I should put

I put a bit random version number here cause I have no idea of what is the difference between version and seafile_version and then seafile_client_version ( which client ? )

./scripts/build/ --version=v6.2.4 --seafile_version=v6.2.4 --libsearpc_version=v3.1.0 --seafile_client_version=v6.2.4

and now I got [ERROR] srcdir must be specified

the --help say --srcdir=SRCDIR Source tarballs must be placed in this directory.

I have no clue of what shoud I put as srcdir with which content into.

Thanks :slight_smile:

Initialliy I just wanted a seafile server with the webapp client to dev :confused:

I tried this guide too

but at the last step ./ is completly broken ( maybe 'cause I’m using mac )

I’m using macOS 10.13.6

Thanks to give some help to have a dev environment on mac.

You try to build seafile. Why not just use a prebuild version?

It also looks like you try running it on mac. It possibly works but I haven’t seen someone doing it and doubt it will actively be supported, so it most likely needs quite some knowledge around running services and building software.

Why not but I didn’t found a tutorial for that either, what I really need is to install the seafile server with a local MySql db on mac. And be able to run the python webserver “seahub” connected to my local server to do some development. But the only tutorial I though for that was and the is not working too on mac.

But it’s not impossible that one day I need to develop a bit into the seafile core in C.

If it doesn’t work the only thing you can do is to try fixing it, so that it runs on your mac.

Another way running running Seafile could be using docker. But that also requires some knowledge around docker.

About this is my error

This is your configuration

    server name:            seafile-local
    server ip/domain:

    seafile data dir:       /Users/me/Dev/haiwen/seafile-data
    fileserver port:        8082

    database:               create new
    ccnet database:         ccnet-db
    seafile database:       seafile-db
    seahub database:        seahub-db
    database user:          seafile

Press ENTER to continue, or Ctrl-C to abort

Generating ccnet configuration ...

Traceback (most recent call last):
  File "", line 1471, in <module>
  File "", line 1424, in main
  File "", line 815, in generate
    if Utils.run_argv(argv, env=env_mgr.get_binary_env()) != 0:
  File "", line 85, in run_argv
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/", line 394, in __init__
    errread, errwrite)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/", line 1047, in _execute_child
    raise child_exception
OSError: [Errno 8] Exec format error

Yep for docker I already have an instance but it’s not the best way to do some development

Especially with bind mounts it should work pretty well. You can also clone GitHub - haiwen/seafile-docker: A Docker image for Seafile server, edit to suit your needs and build a custom image.