I am facing an issue when transferring groups from a deleted user to new owner.
The user was owner of several groups. When I try to share a library to any of these groups the groups owned by the deleted user do not show up (“no group found”). When I try to transfer the group to myself an error message (error_msg: “Internal Server Error”) pops up.
I also recreated the user (same email and username, authentication via keycloak), but it was created without groups or owned libraries. However, in the groups page in the column “owner” the link now works and sends me to the profile of the newly created user, where it is displayed that this user has no groups or owned libraries.
I am running Seafile Server Version: 7.1.4 on docker.
Is this a known issue that might be resolved with an upgrade of seafile server?
did you find a solution for the problem? I also want to delete inactive users from our database. But I see, that some of them are group owners of active groups. What happens to the groups if I delete the owners?
I reactivate this thread, because the problem still persists in Seafile Pro 11.
A user, who is the owner of a group, left our organization without first transferring the group to his successor. Now the other members asked me to do this as the seafile administrator. But I don’t see an option in the group display to do this. I can add members, but I can not change the owner of a group.
How can a seafile admin change the owner of a group?
Just found it out: it’s only possible in the group list. If you search for a group and get the list of results, you can click on the menu (three points) on the right side and chose “transfer”. The menu doesn’t appear if you click on the group to show its properties.