Issue with version 8.0 beta

Hi,

I0ve an issue with version 8.0 beta (Ubuntu Server 18.04 / mySQL / nginx).
When I start ./seahub.sh start I’ve this error :

LC_ALL is not set in ENV, set to en_US.UTF-8
Starting seahub at port 8000 …
Error:Seahub failed to start.
Please try to run “./seahub.sh start” again

I don’t see an error in /logs.

Anyone can help me ?
Thanks

I’m not sure it works on v8, but on earlier versions you could use ./seahub.sh start-fastcgi to get a more verbose output. (I know that fastcgi is no longer in use, still, that was always a first step for me when I didn’t get any output.)
Maybe it’s worth a try for you.

Thanks !

I’ve this message et then end with fastcgi :

File “/opt/seafile/seafile-server-8.0.0/seahub/thirdpart/django/db/backends/mysql/base.py”, line 20, in
) from err
django.core.exceptions.ImproperlyConfigured: Error loading MySQLdb module.
Did you install mysqlclient?
Error:Seahub failed to start.

Please check this FAQ https://cloud.seatable.io/dtable/external-links/7b976c85f504491cbe8e/?tid=0000&vid=0000&row-id=798ca526-d5f5-411e-b48e-40e37aad0bb4

Hello
I had the same issue with the same error and sudo pip3 install mysqlclient fixed it for me
hope that helps you

Thanks daniel.oan and heini.

You’re right heini, the command “pip3 install mysqlclient” is required. But I had many error messages when I tried.
I restarted the install from scratch, and just before that I had to install libmysqlclient-dev (apt-get install libmysqlclient-dev).

My problem is solved, thanks all.