Issues with iPhone using VPN

Solved - see last reply.

For testing, I installed the Seafile official docker on my personal Unraid server. I installed Seadrive on three PCs, and Seafile Pro on two iPhones.

Rather than using (for example) Nginx Proxy Manager to connect via HTTPS, I connect to the server via Wireguard VPN - I do this whenever possible to expose the fewest possible services.

With this configuration, I have no issues with Seafile on the PCs using Seadrive. However, I have one issue with the iPhones:

When I try open files on the iPhones, I receive the error: “Failed to download file [file name]”. I can create and delete folders, but nothing involving files.

I suspect this might relate to the SERVICE_URL and FILE_SERVER_ROOT settings. I think I configured them wrong. Currently I have:
SERVICE_URL = http://[docker IP]:9090
FILE_SERVER_ROOT = http://[docker IP]:9090/seafhttp
I changed from the default port to 9090.

If you don’t think it’s the above, can you point my in the direction for what I should look out for? I know I’ve provided little detail - happy to give more if that helps.

Thanks in advance - cheers.

A follow-up question is, has anyone used Seadrive only via VPN (no HTTPS)? What was your experience like?



I assumed the configuration was held in the Seafile server (seafile.conf and It’s actually held in the database (seahub-db/constance_config) - it pays to read things properly. I restarted the database and problem is now solved.