Konfiguration des Servers

Hallo,
ich möchte den Server auf einen Raspberry Pi betreiben. Der Server ist installiert und lauffähig. Mit einem Client auf einem zweiten Linux-Rechner habe ich auch Zugriff. Jetzt möchte ich den Web-Zugriff konfigurieren. Da ich nur eine dynamische Web-Adresse haben, soll der Web-Zugriff über ‘MeineURL/cloud’ erfolgen. Zusätzlich liegt der Apache-Server noch auf einen anderen Server.
Leider bekomme ich bei dem Aufruf der Seite immer den Fehler:
Es tut uns leid, aber die angefragte Seite wurde nicht gefunden.

In der Datei CCNET.CONF steht:
SERVICE_URL = MeineURL/cloud

In der Datei SEAHUB_SETTINGS.PY steht:
FILE_SERVER_ROOT = ‘MeineURL/cloud/seafhttp’
HTTP_SERVER_ROOT = ‘MeineURL/cloud/seafhttp’

Was muss ich an der Konfiguration ändern, damit der Desktop-Zugriff und der Web-Zugriff funktioniert?

Hi Spacer2020,
willkommen im Seafile Community Forum!
Deine Frage sollte sich direkt aus dem Seafile Manual unter https://manual.seafile.com ergeben bzw. abgeleitet werden können. Schaue mal bitte hier: https://download.seafile.com/published/seafile-manual/deploy/deploy_with_apache.md bzw. dem weiterführenden Beitrag für Zugriff per HTTPS.

Danke, habe ich gelesen. Ich habe meine Konfiguration angepasst. Wenn ich die Webseite intern öffne, dann bekomme ich die Elemente unter media angezeigt. Aber beim Aufruf von extern nicht. Ich habe einen Auszug meine Konfiguration beigelegt.
Frage: Was fehlt in der Konfiguration damit beim externen Aufruf die Webseite richtig dargestellt wird?

Hier der Screenshot von extern.

Das CSS wird offensichtlich nicht richtig geladen.

Für mich gibt es da zwei verschiedene Möglichkeiten:

  • über die Konfiguration:
    In welcher Datei ist welcher Parameter mit welchem Wert einzugeben?

  • über den Quelltext:
    In welcher Datei muss welche Stelle wie geändert werden?

Da Python nicht zu den Programmiersprachen gehört, die ich beherrsche, wäre ich über Unterstützung dankbar.

Am Quelltext muss sicher nichts geändert werden - wenn Du nicht selbst dort schon was geändert hast. Die RasPi Version läuft auf vielen Geräten reibungslos ohne Coding.

Ich wiederhole mich: Deine Frage sollte sich direkt aus dem Seafile Manual unter https://manual.seafile.com ergeben bzw. abgeleitet werden können. Es kann nicht Aufgabe des Forums sein, die Anleitung wiederzugeben. Dort steht drin, wie Seafile zu konfigurieren ist. Darüber hinaus gibt es noch das Seafile Community Manual unter https://seafile.readthedocs.io/en/latest/, das für genau solche Fragestellungen zusammengestellt wurde.

Außerdem: Wie soll erklärt werden, wie Deine Konfiguration anzupassen ist, wenn Du nur einen Bruchteil Deiner Konfig-Dateien hier postet?