LDAP Integration in Seafille 11.0.6

Hi there,

I don’t know any more advice…

I installed a new Seafile CE 11.0.6 Server on Ubuntu 22.04 LTS. Everything works fine.
But I have huge problems with implementing LDAP in Seafile with my Windows AD.

In all my logs (on Seafile Server and Windows Server) I can´t see any serious errors.
The only error I can see is, that in seahub.log stands:
[ERROR] seahub.base.accounts:987 authenticate ldap user test@domain.intern not found.
I cannot login with this test user.

My enviroment:

The seafile server is in the same subnet as the AD Server and they can speech to each other. The LDAP ports are open. I want to do LDAP without the secure option.
I have a security group in my AD, so every user which is in there should be able to sign in to Seafile.
The user which I use for LDAP is a normal Domain user. But I already tried this with a domain admin and this did not work.

My seahub_settings.py has the following included:

#LDAP

ENABLE_LDAP = True
LDAP_SERVER_URL = ‘ldap://172.19.0.251’
LDAP_BASE_DN = ‘CN=Users,dc=domain,dc=intern’
LDAP_ADMIN_DN = ‘user@domain.intern’
LDAP_ADMIN_PASSWORD = ‘whatever’
LDAP_LOGIN_ATTR = ‘mail’
LDAP_FILTER = ‘memberOf=CN=Seafile,CN=Users,DC=domain,DC=intern’
LDAP_USER_FIRST_NAME_ATTR = ‘givenName’
LDAP_USER_LAST_NAME_ATTR = ‘sn’
LDAP_USER_NAME_REVERSE = False
LDAP_CONTACT_EMAIL_ATTR = ‘’
LDAP_USER_ROLE_ATTR = ‘’
LDAP_PROVIDER = ‘ldap’

Any ideas where I can find more information to troubleshoot?
Or even better ideas which could be fixing this?

If there are any information missing feel free to ask at any time.

Greetings
Marcel

Forget it I solved it. Its too late.

But I leave this thread for everyone doing a nightsession. :slight_smile:

The solution was the mail attribute.
When you say to LDAP, check Users Mail Attribute, but you forgot to add this to your AD user, then it might be difficult to work. Furthermore, I forgot to add a second OU to the BASE_DN.

1 Like

Btw, I suggest to use userPrincipalName instead of mail because it is possible to have 2 domain accounts with the same email.