LibreOffice Converter issue

I’ve upgraded to Ubuntu 16.04 with no real issues. I’ve using the community edition for quite a while and after reading some information I decided to try the Pro edition (< 3 users) so I have libreoffice installed and the python extensions however after I still can not view do/docx/xls/xlsx/ppt files. [code]
[2016-10-11 08:16:43,312] [DEBUG] start to fetch task <type: xls, id: 7366beda369f64882f3788c68ec2597c056dfbc2>
[2016-10-11 08:16:43,372] [WARNING] error when invoking libreoffice: unoconv: Cannot find a suitable pyuno library and python binary combination in /usr/lib/libreoffice
ERROR: No module named uno

unoconv: Cannot find a suitable office installation on your system.
ERROR: Please locate your office installation and send your feedback to:
Issues · unoconv/unoconv · GitHub

[2016-10-11 08:16:43,373] [WARNING] failed to convert <type: xls, id: 7366beda369f64882f3788c68ec2597c056dfbc2> from excel to html
[2016-10-11 08:16:43,373] [DEBUG] removing temporary document /tmp/tmplcQTfG.xls

Now from python:[code]
~$ python
Python 2.7.12 (default, Jul 1 2016, 15:12:24)
[GCC 5.4.0 20160609] on linux2
Type “help”, “copyright”, “credits” or “license” for more information.

import uno
Traceback (most recent call last):
File “”, line 1, in
ImportError: No module named uno

~/Seafile-Pro/logs$ locate


Now I’ve installed the “script-provider” however I believe the issue is in locating the home directory for libreoffice. Which I haven’t quite found a work around for.
I was wondering if anyone else had any issues with the office converter under a fresh installation.

The is in Python 3 dir. I guess it should be 2.7?

What’s the seafile pro server version are you using?

There was a bug for seafile server to work with libreoffice 5.x (which is the default on ubunt 16.04). We have fixed it in seafile pro 6.0.

seafile-pro-server-5.1.11, well I guess that would explain it.
Which I’ve downloaded from

You can find pro 6.0 in the “beta” folder: .

Thank you, the transition was seemless, other than the 2Mb limit, edited the seafevents.conf. I’m good. Works like a dream. Now my only caveat is audio/video decoding and streaming with symbolic links to my fuse directory, unless you can incorporate streaming into seahub. Very well done.

I tried to install the office convertes for preview. but had no luck so far.
see my own topic Office preview not working