Markdown editor not working?

I’ve installed the community seafile server in docker in my homelab. It generally works ok, except the markdown editor doesn’t seem to work.
From the web interface I click New > New markdown file, then click it when it’s created, but all that happens is it makes this pinging animation in the middle of the page, nothing else. Never opens a markdown editor or anything. Is that how it’s supposed to be?

I (mostly) don’t have any problems with the markdown editor. The pinging animation is there for me as well, but that’s just the loading animation which should go away after a short time.
Sometimes it doesn’t load correctly but refreshing the page helps.

Have you tried a different browser?

I’m not using the docker version though. Hence, I’m sorry that I can’t really help you. I can only confirm that something is not working as intended.

After some poking around, I found two settings under System Admin > Settings: SERVICE_URL and FILE_SERVER_ROOT that were incorrectly set. After setting them correctly the editing functions work as they should, thanks.

I’m not sure but I’d expect they should have been set in the docker start script. I followed the instructions on download dot seafile dot com slash published slash seafile-manual slash docker slash but no mention of this. (sorry but this site doesn’t allow link, not even to itself)

Actually, now I restarted the stack and now I just get a 502 Bad Gateway when I go to the seafile URL.

I don’t know for sure if this is linked to the changed settings, but it’s the only thing I changed so …

Edit. Ended with removing the container completely and starting over. Don’t know that I did anything different than first time around, but now it works.