Massive CPU hog due to extensive logging

Hi all,

Seafile client 6.1.5 on MacOS version 10.13.4 talking to Seafile Pro Server 6.0.8 running on Ubuntu 16.04 LTS.

This happens:

Any ideas?



It appears to be failing to access the worktree for the repo, and therefore, it keeps trying. Stop seafile and seahub and run seaf-fsck on the repo and also run seaf-gc. Check the manual for the options.

You may also want to try upgrading Seafile Server to a newer version. There have been some fixes recently regarding duplicated logging.

Thanks. I’ll update the server; yet this logging happens client-side. And yes, there are two local repositories that are not accessible - which are simply on external disks that I don’t always carry. It would be great to be able to configure the client to not be as verbose when logging. Then, there is the concurrent repeating errors in the client log as shown in the video.

For now I’ve ln -s /dev/null seafile.log, and the rest is silence. Seafile client seems to be less annoyed by that when restarting compared to earlier versions.

I’m running much later versions than you and I’m not having that logging problem with my client or server. Which client log was it?

Seafile.log - Actually, when I ask the client whether it finds a new version available, it says no.

It usually does respond with no. That function has never been reliable with the Seafile Client. It’s best to check the website for the latest version. 6.1.7 is the latest version of the Windows and Mac client. 6.2.5 is the latest server version.

Also, keep in mind that the server does pass logging messages to the client, so just going with a later version of the client may not minimize those logs. Those logs are sent from the repo-mgr, which is handled by the server. So, updating your server may help.

Be aware that there have been significant changes since 6.0 and you’ll need to read the changelog carefully. Also, carefully follow the upgrade path. You are two versions behind.

Thanks for that pointer. I’ve updated the client to the latest version. The excessive log does not show, but the excessive log about absent repositories remains. I’ve hence again ln -s /dev/null seafile.log ¯_(ツ)_/¯

1 Like

So, are you saying that it’s solved with the update to the latest client? If so, put [SOLVED] at the beginning of the title of this thread and I’ll tag @shoeper to mark the solution.

At least I don’t see it anymore, but there were two excessive loggings: First about the missing repository, and that remains. And then the one I made the video about, and that had already disappeared by restarting the client. So I don’t know whether it’s solved.

1 Like